Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 189113 - Rerun last unit test
Rerun last unit test
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Test Runner
6.x
PC Linux
: P3 with 2 votes (vote)
: TBD
Assigned To: Theofanis Oikonomou
issues@utilities
:
: 210978 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-01 13:55 UTC by admirau
Modified: 2013-02-16 01:53 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
a patch (3.65 KB, patch)
2013-02-05 16:29 UTC, Theofanis Oikonomou
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description admirau 2010-08-01 13:55:22 UTC
Running unit tests via ctrl+F6 is fine.
Sometimes after the test I go to other file,
and then I want to rerun the test.

There is an icon 'Rerun' in the Test results window, but there is no corresponding option in the menu and no keyboard shortcut for this.

It would be nice to have a shortcut to run the test again.
Comment 1 Tomas Mysik 2010-08-04 08:40:38 UTC
Please evaluate, thanks.
Comment 2 Theofanis Oikonomou 2013-01-08 15:06:56 UTC
*** Bug 210978 has been marked as a duplicate of this bug. ***
Comment 3 BullfrogBlues 2013-01-12 17:03:09 UTC
There are also missing keymap shortcuts in (PHP/PHPUnit) to:

- rerun tests
- rerun failed tests

These would be very useful.

Again, there icons in the Test Results view, but the ability to set shortcuts is missing.
Comment 4 Theofanis Oikonomou 2013-02-05 16:29:39 UTC
Created attachment 131042 [details]
a patch

This patch makes the rerun/rerun failed actions available so that the user can set a shortcut in options. It would be good to have a standard shortcut though. I the patch I have set them to D-J and D-F10 respectively just as an example.

Honza any comments on if such shortcuts should be set by default for those two actions and if yes which ones? Thank you
Comment 5 Jan Peska 2013-02-06 08:17:11 UTC
D-J seems OK, but D-F10 is already used for a window system action - it gives focus to tabs in multi-tabs documents. It is not a global action (it can be invoked only from editor) but I'm not 100% sure we can use it. Petr Somol plans to do a full review of shortcuts in the IDE so I would suggest to wait until it's finished. It is possible there are better candidates for these shortcuts.
Comment 6 Theofanis Oikonomou 2013-02-14 10:36:15 UTC
Changeset: 5288c5d9f2f3
Author:    Theofanis Oikonomou <theofanis@netbeans.org>
Date:      2013-02-14 11:28
Message:   
Issue #189113 - Rerun last unit test
Comment 7 Quality Engineering 2013-02-16 01:53:27 UTC
Integrated into 'main-golden', will be available in build *201302152300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5288c5d9f2f3
User: Theofanis Oikonomou <theofanis@netbeans.org>
Log: Issue #189113 - Rerun last unit test


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo