Bug 188999 - AIOOBE from TaskModel.getSelectedHandle
AIOOBE from TaskModel.getSelectedHandle
Status: RESOLVED DUPLICATE of bug 192420
Product: platform
Classification: Unclassified
Component: Progress
7.0
PC Linux
: P3 (vote)
: TBD
Assigned To: Jan Peska
issues@platform
http://deadlock.netbeans.org/hudson/j...
: RANDOM, TEST, THREAD
: 190798 196129 205082 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 23:00 UTC by Jesse Glick
Modified: 2011-11-23 10:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2010-07-27 23:00:14 UTC
BuildImplTest.testJavadocPackagesDocumented failed due to an uncaught runtime exception manipulating progress handles:

java.lang.ArrayIndexOutOfBoundsException: 0 >= 0
	at java.util.Vector.elementAt(Vector.java:427)
	at javax.swing.DefaultListModel.getElementAt(DefaultListModel.java:70)
	at org.netbeans.modules.progress.spi.TaskModel.getSelectedHandle(TaskModel.java:154)
	at org.netbeans.modules.progress.spi.TaskModel.updateSelection(TaskModel.java:91)
	at org.netbeans.modules.progress.spi.Controller.toIndeterminate(Controller.java:158)
	at org.netbeans.modules.progress.spi.InternalHandle.toIndeterminate(InternalHandle.java:182)
	at org.netbeans.api.progress.ProgressHandle.switchToIndeterminate(ProgressHandle.java:106)
	at org.apache.tools.ant.module.bridge.impl.NbBuildLogger.checkForStop(NbBuildLogger.java:204)
	at org.apache.tools.ant.module.bridge.impl.NbBuildLogger.messageLogged(NbBuildLogger.java:583)
...

Looks to me like TaskModel reads & writes the 'model' field without apparent synchronization. Not sure if the InternalHandle lock is supposed to control all accesses.
Comment 1 Jan Peska 2011-08-11 14:51:34 UTC
*** Bug 196129 has been marked as a duplicate of this bug. ***
Comment 2 Jan Peska 2011-11-03 09:51:32 UTC
*** Bug 190798 has been marked as a duplicate of this bug. ***
Comment 3 Jan Peska 2011-11-14 13:49:25 UTC
*** Bug 205082 has been marked as a duplicate of this bug. ***
Comment 4 Jan Peska 2011-11-23 10:43:31 UTC

*** This bug has been marked as a duplicate of bug 192420 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo