Bug 188984 - I18N - multibyte characters can not be displayed in Output window
I18N - multibyte characters can not be displayed in Output window
Status: RESOLVED INVALID
Product: cnd
Classification: Unclassified
Component: I18N
6.x
Sun Solaris
: P2 (vote)
: TBD
Assigned To: issues@cnd
issues@cnd
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-27 11:02 UTC by Keiichi Oono
Modified: 2010-07-28 03:27 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
screen-shot on "ja" locale in Solaris 10. (96.77 KB, image/png)
2010-07-27 11:03 UTC, Keiichi Oono
Details
screen-shot on "ja_JP.UTF-8" locale in Solaris 10 (102.94 KB, image/png)
2010-07-27 11:04 UTC, Keiichi Oono
Details
"Encoding" list box (57.31 KB, image/png)
2010-07-27 12:13 UTC, soldatov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Keiichi Oono 2010-07-27 11:02:00 UTC
to reproduce
 - Run NetBeans C/C++ in multi-byte locale (such as "ja" or "zh" on Solaris 10)
 - Set toolset to "OracleSolarisStudio"
 - Open/Create sample projcect (e.g. Welcome)
 - Build proejct

The output from localized Oracle Solaris Studio can not be displayed in the output window. The characters are corrupted.

All the characters are displayed when executed in UTF-8 locale (e.g. ja_JP.UTF-8 on Solaris 10). This problem is caused only when non UTF-8 locale is used.

And also, this problem is not caused when GNU tools are being used because GNU tools does not output localized characters (it's always English).
Comment 1 Keiichi Oono 2010-07-27 11:03:22 UTC
Created attachment 101041 [details]
screen-shot on "ja" locale in Solaris 10.

The output from dmake is corrupted when executing in "ja" locale in Solaris 10.
Comment 2 Keiichi Oono 2010-07-27 11:04:36 UTC
Created attachment 101043 [details]
screen-shot on "ja_JP.UTF-8" locale in Solaris 10

All the characters are displayed correctly in ja_JP.UTF-8 locale.
Comment 3 soldatov 2010-07-27 11:45:05 UTC
Can you set your encoding in C/C++ > Build Tools > Encoding list box in Options window?
Comment 4 soldatov 2010-07-27 12:13:27 UTC
Created attachment 101047 [details]
"Encoding" list box
Comment 5 Keiichi Oono 2010-07-28 03:27:55 UTC
Thank you, soldatov. The multi-byte characters are displayed correctly by configuring Encoding. 

  Solaris 10 "ja" locale : EUC-JP
  Solaris 10 "zh" locale : GB2312

It's not a bug, but a user error. I close this as resolved/invalid.
Again, thank you.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo