Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 188971 - Code folding in "if's", "for's" block "{}" etc.
Code folding in "if's", "for's" block "{}" etc.
Status: RESOLVED DUPLICATE of bug 186731
Product: php
Classification: Unclassified
Component: Editor
6.x
PC All
: P3 with 1 vote (vote)
: TBD
Assigned To: rmatous
issues@php
http://opti-eoa.com
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-26 22:24 UTC by zamaliphe
Modified: 2011-11-16 16:40 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zamaliphe 2010-07-26 22:24:45 UTC
Code folding "if's", "for's", foreach's, etc, is the only thing that Netbeans lacks of (and most text-editors/IDE, for that matter). Yes, you can use custom-folds, but that's not pratical at all.
If done right, you could code fold a "if" with html code inside of if.

Example:

<?php if (bla) { ?>
<table>...</table>
<? } ?>

( or with "if (bla):" and "endif;" )
Comment 1 AIML_Engr 2010-08-16 14:02:12 UTC
This issue has been submitted several times. Duplicate is as marked.

*** This bug has been marked as a duplicate of bug 186731 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo