Bug 188954 - fix imports on compile option
fix imports on compile option
Status: RESOLVED DUPLICATE of bug 89036
Product: java
Classification: Unclassified
Component: Compiler
6.x
PC Windows Vista
: P3 (vote)
: 7.0
Assigned To: Dusan Balek
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-26 12:55 UTC by jonathancrosmer
Modified: 2013-12-18 22:21 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jonathancrosmer 2010-07-26 12:55:01 UTC
I'm looking for a very simple enhancement:  the option in the java editor to run "fix imports" before any compile/build/run/debug, or perhaps to run it only if there are import errors preventing compilation.  So many times I push the button to run project, debug, run file, etc. and it fails for exactly one reason: need to import something really obvious that the IDE is able to guess with Fix Imports.  It would be great if NB figured this out, fixed it automatically, and continued with the previous action.

Product Version: NetBeans IDE 6.9 (Build 201006101454)
Java: 1.6.0_20; Java HotSpot(TM) Client VM 16.3-b01
Comment 1 markiewb 2013-12-18 22:21:32 UTC
You want it as a save action? Dup of #89036

*** This bug has been marked as a duplicate of bug 89036 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo