Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 188716 - Skipped JUnit tests are marked as "passed" by Netbeans
Skipped JUnit tests are marked as "passed" by Netbeans
Status: RESOLVED DUPLICATE of bug 186276
Product: java
Classification: Unclassified
Component: JUnit
6.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: Victor Vasilyev
junit-issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 22:19 UTC by gborkowski
Modified: 2010-07-16 06:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gborkowski 2010-07-15 22:19:05 UTC
This is very long-standing and annoying bug in Netbeans. When you run JUNit tests, they are either marked with red and with label "FAILED" or marked green with label "PASSED". But the skipped tests (e.g. those marked with @Ignore) are also marked with green color and label "PASSED". It is extremely confusing. I've already seen many cases when it caused real problems, because people were sure that all tests passed, when in fact all tests were skipped.
In eclipse skipped tests are marked with yellow, labeled "SKIPPED". That's not rocket since. Please, fix it in Netbeans 6.9.1 too - that's probably 10-minutes job to do.
Comment 1 Alexei Mokeev 2010-07-16 06:29:01 UTC
Ignored tests should not be shown in output at all, it's a consequence of how Ant handles that. 

If by any chance @Ignore tests are shown as passed please provide more details in #186276.

*** This bug has been marked as a duplicate of bug 186276 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo