Bug 188700 - UI frozen for several seconds after right-clicking a file in Favorites
UI frozen for several seconds after right-clicking a file in Favorites
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P2 (vote)
: 7.0
Assigned To: Jesse Glick
issues@projects
: PERFORMANCE, THREAD
: 177709 (view as bug list)
Depends on:
Blocks: 152526
  Show dependency treegraph
 
Reported: 2010-07-15 13:59 UTC by Petr Jiricka
Modified: 2010-09-24 11:23 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump while the UI war frozen (20.26 KB, text/plain)
2010-07-15 13:59 UTC, Petr Jiricka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2010-07-15 13:59:58 UTC
Created attachment 100856 [details]
Thread dump while the UI war frozen

Right-clicked a Java file in the Favorites view (this was a versioned file and I wanted to see the history), and the UI froze for a few seconds. Looks like it is waiting for network access.

Thread dump is attached.
Comment 1 Jan Lahoda 2010-08-02 13:23:13 UTC
Waiting for HTTP javadoc is a consequence of bug #41443. But, action's isEnabled should be as quick as possible and should not require access to parsing infrastructure, as that may block under many circumstances.
Comment 2 Jesse Glick 2010-08-02 15:02:01 UTC
Agreed that DefaultReplaceTokenProvider is at fault for waiting for SourceUtils.getMainClasses. But independently of that, couldn't ElementScanningTask be running in parallel with other source model tasks? Does it need to know parameter names immediately?
Comment 3 Jesse Glick 2010-08-02 21:01:20 UTC
It does in fact call SourceUtils.isScanInProgress(), but this returns false. I suppose it should use SourceUtils.isMainClass instead of SourceUtils.getMainClasses?
Comment 4 Jesse Glick 2010-08-02 21:12:00 UTC
core-main #fa5efa896150
Comment 5 Quality Engineering 2010-08-04 03:07:41 UTC
Integrated into 'main-golden', will be available in build *201008040001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/fa5efa896150
User: Jesse Glick <jglick@netbeans.org>
Log: #188700: UI frozen for several seconds after right-clicking a file in Favorites
Comment 6 Antonin Nebuzelsky 2010-09-24 11:23:52 UTC
*** Bug 177709 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo