Bug 188685 - Rebase extension support
Rebase extension support
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P3 with 2 votes (vote)
: 7.4
Assigned To: Ondrej Vrabec
issues@versioncontrol
: PLAN
: 206418 (view as bug list)
Depends on:
Blocks: 226415
  Show dependency treegraph
 
Reported: 2010-07-15 08:05 UTC by prodoc
Modified: 2013-02-23 04:09 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description prodoc 2010-07-15 08:05:23 UTC
The MQ rebase extension is quite handy to use. Support for it in NetBeans would be highly appreciated.

http://mercurial.selenic.com/wiki/RebaseExtension
Comment 1 Ondrej Vrabec 2012-12-14 09:00:46 UTC
i would like to at least evaluate how much work it is and potentially implement rebase
Comment 2 Ondrej Vrabec 2013-02-11 13:43:59 UTC
*** Bug 206418 has been marked as a duplicate of this bug. ***
Comment 3 Ondrej Vrabec 2013-02-11 13:44:28 UTC
do not forget to offer rebase after a pull
Comment 4 Ondrej Vrabec 2013-02-20 16:27:28 UTC
pull --rebase -> fixed in core-main #8a0a1fb56125
pull in general, specifying parameters etc. -> fixed in core-main #8fa9381efd00
Comment 5 prodoc 2013-02-20 17:55:38 UTC
Great, many thanks for implementing this.
Comment 6 Quality Engineering 2013-02-23 04:09:17 UTC
Integrated into 'main-golden', will be available in build *201302222300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/8a0a1fb56125
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #188685 - Rebase extension support
offer rebase after a pull


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo