Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 188677 - IllegalStateException: Dialog was not created correctly
IllegalStateException: Dialog was not created correctly
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: Exceptions Reporter
6.x
All All
: P2 with 1 vote (vote)
: 7.1
Assigned To: Tomas Danek
logger-issues@ide
EXCEPTIONS_REPORT jdk_bug_7030206
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 00:36 UTC by pekarna
Modified: 2011-10-20 14:25 UTC (History)
36 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (403 bytes, text/plain)
2010-07-15 00:36 UTC, pekarna
Details
stacktrace (930 bytes, text/plain)
2010-07-27 19:22 UTC, Jesse Glick
Details
stacktrace (930 bytes, text/plain)
2010-08-31 10:57 UTC, Sergey Petrov
Details
stacktrace (403 bytes, text/plain)
2010-10-06 13:16 UTC, aldobrucale
Details
stacktrace (930 bytes, text/plain)
2010-12-07 08:12 UTC, rohitbrai
Details
stacktrace (930 bytes, text/plain)
2011-01-24 20:18 UTC, misterm
Details
stacktrace (930 bytes, text/plain)
2011-02-24 13:51 UTC, michbarsinai
Details
stacktrace (930 bytes, text/plain)
2011-02-26 12:33 UTC, javadimon
Details
stacktrace (930 bytes, text/plain)
2011-06-04 17:17 UTC, theshadow27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pekarna 2010-07-15 00:36:15 UTC
Build: NetBeans IDE 6.9 (Build 201006101454)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Linux

User Comments:
muhammadghazali: This exception occured while I changed my php project name.

pekarna: Typed a start of a class name and pressed Ctrl+space. NetBeans already were in an inconsistent state (see my previous report).




Stacktrace: 
java.lang.IllegalStateException: Dialog was not created correctly
   at org.netbeans.modules.uihandler.Installer$SubmitInteractive.createDialog(Installer.java:1991)
   at org.netbeans.modules.uihandler.Installer$Submit.run(Installer.java:1600)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1418)
   at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1957)
Comment 1 pekarna 2010-07-15 00:36:19 UTC
Created attachment 100840 [details]
stacktrace
Comment 2 Jesse Glick 2010-07-27 19:22:27 UTC
Created attachment 101055 [details]
stacktrace
Comment 3 Sergey Petrov 2010-08-31 10:57:44 UTC
Created attachment 101769 [details]
stacktrace

remove some part of text, try to remove more
Comment 4 aldobrucale 2010-10-06 13:16:06 UTC
Created attachment 102282 [details]
stacktrace

Invoking "change method parameters"
Comment 5 Jesse Glick 2010-10-22 21:17:53 UTC
Occurred after I tried to report an unrelated exception which was a recurrent NPE during editor repaint.
Comment 6 rohitbrai 2010-12-07 08:12:33 UTC
Created attachment 103654 [details]
stacktrace

Changed the min project using set as main project.
Comment 7 misterm 2011-01-24 20:18:32 UTC
Created attachment 105318 [details]
stacktrace
Comment 8 michbarsinai 2011-02-24 13:51:37 UTC
Created attachment 106408 [details]
stacktrace

after closing the project setup dialog.
Comment 9 javadimon 2011-02-26 12:33:49 UTC
Created attachment 106473 [details]
stacktrace
Comment 10 Exceptions Reporter 2011-03-09 12:06:54 UTC
This bug already has 100 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=170473
Comment 11 Tomas Danek 2011-03-09 12:54:45 UTC
java.lang.NullPointerException
	at javax.swing.text.html.StyleSheet.getRule(StyleSheet.java:210)
	at javax.swing.text.html.StyleSheet$ViewAttributeSet.<init>(StyleSheet.java:2676)
	at javax.swing.text.html.StyleSheet.getViewAttributes(StyleSheet.java:330)
	at javax.swing.text.html.BlockView.setPropertiesFromAttributes(BlockView.java:387)
	at javax.swing.text.html.BlockView.setParent(BlockView.java:57)
	at javax.swing.plaf.basic.BasicTextUI$RootView.setView(BasicTextUI.java:1316)
	at javax.swing.plaf.basic.BasicTextUI.setView(BasicTextUI.java:678)
	at javax.swing.plaf.basic.BasicTextUI.modelChanged(BasicTextUI.java:667)
	at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.propertyChange(BasicTextUI.java:1792)
	at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:339)
	at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:276)
	at java.awt.Component.firePropertyChange(Component.java:8128)
	at javax.swing.text.JTextComponent.setEditable(JTextComponent.java:1781)
	at org.netbeans.modules.uihandler.Installer$SubmitInteractive$1.run(Installer.java:1959)

is the the root cause stacktrace for exc.report problem. It seems to me like JDK bug, really do not know what might be wrong on

browser.setEditable(false);

where 

browser = new JEditorPane();

Will take a look anyway.
Comment 12 Marian Mirilovic 2011-03-09 16:12:28 UTC
JDK problem from my point of view .. similar issue 194458
Comment 13 Tomas Danek 2011-03-21 14:22:24 UTC
Based on time when this exception started to appear, i took a look and do not see any possible related change in 
/org/netbeans/modules/uihandler/Connecting.html (which is valid)
 nor in
org.netbeans.modules.uihandler.Installer.java
Comment 14 Antonin Nebuzelsky 2011-03-23 13:06:43 UTC
Reported to JDK team as 7030206.

Closing on our side while waiting for evaluation of the JDK bug report.
Comment 15 Antonin Nebuzelsky 2011-05-16 08:28:43 UTC
The JDK bug was closed with a comment about threading issue on our side - "The fact that the exception is sporadically thrown indicates a threading problem. Please make sure that the provided code is run on the Event Dispatching Thread (see SwingUtilities.isEventDispatchThread())." And if we are sure the problem is not in our code, we should provide a standalone test without NetBeans, our provide more information. See what we provided so far at
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7030206

Reassigning back to the module for evaluation.
Comment 16 theshadow27 2011-06-04 17:17:52 UTC
Created attachment 108724 [details]
stacktrace

In Java (SE) class library project: In right-click context menu on package node in Projects pane, clicked "rename"
Comment 17 Stanislav Aubrecht 2011-06-14 09:29:49 UTC
(In reply to comment #11)
> 
> is the the root cause stacktrace for exc.report problem. It seems to me like
> JDK bug, really do not know what might be wrong on
> 
> browser.setEditable(false);
> 
> where 
> 
> browser = new JEditorPane();
> 
> Will take a look anyway.

i'm only guessing but JEditorPane needs to render the text as disabled and because it's showing HTML text it uses some sort of CSS to change text color. and there's bug in the HTML text or in the JDK or both.
the problem should be reproducible in a plain swing app using the same HTML text
Comment 18 Tomas Danek 2011-10-19 13:32:14 UTC
core-main
205306:c83cee1d3057
Comment 19 Quality Engineering 2011-10-20 14:25:51 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/c83cee1d3057
User: musilt2@netbeans.org
Log: #188677:  IllegalStateException: Dialog was not created correctly


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo