Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 188482 - Debugger does not stop on a breakpoint
Debugger does not stop on a breakpoint
Status: RESOLVED WONTFIX
Product: javafx
Classification: Unclassified
Component: Debugger
7.0
PC Windows XP
: P2 (vote)
: 7.0.1
Assigned To: Michal Skvor
issues@javafx
:
: 188492 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-08 10:59 UTC by Alexandr Scherbatiy
Modified: 2011-05-16 13:52 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2010-07-08 10:59:35 UTC
JavaFX Composer FXJDI Build #49 (Jul 8, 2010 7:48:33 AM)

See the issue 187479  

Steps to reproduce:
 - Create Bounce sample, 
 - Set breakpoint at line 53
 - Debug the project

Thde debugger does not stop on the breakpoint.

See the screenshot:
http://netbeans.org/bugzilla/attachment.cgi?id=100687
Comment 1 Michal Skvor 2010-07-12 13:56:15 UTC
Filed as issue to jira.
http://javafx-jira.kenai.com/browse/JFXC-4481
Comment 2 Michal Skvor 2010-08-03 13:21:43 UTC
Not fixed yet in fxjdi. Postponing it.
Comment 3 Michal Skvor 2010-08-03 13:23:27 UTC
This seems to be duplicate of issue #188492. Because there is no code on the var c line then the debugger does not step on the line at all.

*** This bug has been marked as a duplicate of bug 188492 ***
Comment 4 Michal Skvor 2010-08-03 14:57:02 UTC
*** Bug 188492 has been marked as a duplicate of this bug. ***
Comment 5 Alexandr Scherbatiy 2010-08-04 08:26:02 UTC
Steps from issue 188492 

- Copy the code to Main file:
-----------------------------------
var a = 10;
var b = a + 10;
var c = b + 40;

println("c");
-----------------------------------

- Set a breakpoint to 'b' variable declaration (second line)
- Debug the project

- Press F7 (Step Into)
 The Current program Counter jumps to the last line 'println("c");'
  instead of the next line  'var c = b + 40;'
Comment 6 David Strupl 2011-05-16 13:52:58 UTC
Closing all bugs filed against JavaFX 1.x as wontfix. We will support JavaFX 2.0 - please keep opened only bugs against the new release. Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo