Bug 188368 - LowPerformance took 23923 ms.
LowPerformance took 23923 ms.
Status: RESOLVED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Team Framework
6.x
All All
: P3 (vote)
: 7.0
Assigned To: Tomas Stupka
issues@connecteddeveloper
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-05 03:13 UTC by Catchwa
Modified: 2012-10-18 10:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (6.82 KB, application/nps)
2010-07-05 03:13 UTC, Catchwa
Details
jaxb-api-osgi.jar locks (GF & NB running) (44.12 KB, image/png)
2010-07-13 00:55 UTC, Catchwa
Details
jaxb-api-osgi.jar locks (GF stopped, NB running) (42.15 KB, image/png)
2010-07-13 00:56 UTC, Catchwa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Catchwa 2010-07-05 03:13:49 UTC
Build: NetBeans IDE 6.9 (Build 201006101454)
VM: Java HotSpot(TM) Client VM, 14.3-b01, Java(TM) SE Runtime Environment, 1.6.0_17-b04
OS: Windows XP

User Comments:
GUEST: When I open Netbeans

GUEST: just started netbeans ide

teknoid: Starting IDE. Scanning projects.

Catchwa: Starting up NetBeans. "Opening Projects" was running (and still is). Tried clicking *anywhere*



Maximum slowness yet reported was 23923 ms, average is 9167
Comment 1 Catchwa 2010-07-05 03:13:53 UTC
Created attachment 100597 [details]
nps snapshot
Comment 2 Jan Becicka 2010-07-08 06:49:50 UTC
It looks like AWT is blocked by class loading. This is probably caused by disk activity invoked by indexing. I have no idea how to avoid it.
Comment 3 Catchwa 2010-07-13 00:55:27 UTC
Created attachment 100787 [details]
jaxb-api-osgi.jar locks (GF & NB running)

jaxb-api-osgi.jar locks when GlassFish is started with no applications deployed
Comment 4 Catchwa 2010-07-13 00:56:26 UTC
Created attachment 100788 [details]
jaxb-api-osgi.jar locks (GF stopped, NB running)

jaxb-api-osgi.jar locks when GlassFish is stopped (no applications deployed to GlassFish from when it is started to when it is stopped)
Comment 5 Catchwa 2010-07-13 00:58:00 UTC
Apologies, attachments added to the wrong bug. (should have been 188514)
Comment 6 Vitezslav Stejskal 2010-08-03 09:13:07 UTC
(In reply to comment #2)
> It looks like AWT is blocked by class loading.
Yes

> This is probably caused by disk activity
Yes

> invoked by indexing.
No. Look at the Parsing & Indexing thread - it's idle.
Comment 7 Tomas Stupka 2012-10-18 10:06:17 UTC
no reports since 2010. closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo