Bug 188249 - [69cat] java.sql.SQLException: Unsupported feature
[69cat] java.sql.SQLException: Unsupported feature
Status: RESOLVED WONTFIX
Product: db
Classification: Unclassified
Component: DB schema
6.x
All All
: P3 (vote)
: 7.1
Assigned To: Jiri Rechtacek
issues@db
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 15:10 UTC by esmithbss
Modified: 2011-10-26 14:21 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.38 KB, text/plain)
2010-06-30 15:10 UTC, esmithbss
Details
stacktrace (1.38 KB, text/plain)
2010-06-30 18:35 UTC, esmithbss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2010-06-30 15:10:23 UTC
This bug was originally marked as duplicate of bug 155003, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201006290001)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Windows XP

User Comments:
esmithbss: Cancelled the Hibernate Reverse Engineering wizard prior to retrieval of database schema data, but after establishing the connection.




Stacktrace: 
java.sql.SQLException: Unsupported feature
   at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:134)
   at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:179)
   at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:269)
   at oracle.jdbc.dbaccess.DBError.throwUnsupportedFeatureSqlException(DBError.java:689)
   at oracle.jdbc.OracleDatabaseMetaData.getDatabaseMajorVersion(OracleDatabaseMetaData.java:4442)
   at org.netbeans.modules.dbschema.jdbcimpl.SchemaElementImpl.getOracleRecycleBinTables(SchemaElementImpl.java:730)
Comment 1 esmithbss 2010-06-30 15:10:27 UTC
Created attachment 100525 [details]
stacktrace
Comment 2 esmithbss 2010-06-30 18:35:12 UTC
Created attachment 100527 [details]
stacktrace

Hibernate Reverse Engineering Fails to find Primary Keys.
Comment 3 esmithbss 2010-06-30 18:45:24 UTC
<long post>
It appears that this is tied to the ability to reverse engineer hibernate
components from an Oracle database.  This is thrown when the attempt is made to
obtain the Oracle schema.

The retrieved data does not have any details regarding Primary Keys so I would
recommend checking out that section of the Hibernate Reverse Engineering Wizard
to determine what is happening.

I have confirmed that the tables in question do have primary keys (validated
via SQL*Plus, Toad, and Oracle SQL*Developer tools).


I cannot attach the log file due to company policy; however, there are a few items from the log file that are telling:



java.sql.SQLException: Unsupported feature
	at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:134)
	at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:179)
	at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:269)
	at oracle.jdbc.dbaccess.DBError.throwUnsupportedFeatureSqlException(DBError.java:689)
	at oracle.jdbc.OracleDatabaseMetaData.getDatabaseMajorVersion(OracleDatabaseMetaData.java:4442)
	at org.netbeans.modules.dbschema.jdbcimpl.SchemaElementImpl.getOracleRecycleBinTables(SchemaElementImpl.java:730)
	at org.netbeans.modules.dbschema.jdbcimpl.SchemaElementImpl.initTables(SchemaElementImpl.java:242)
	at org.netbeans.modules.dbschema.jdbcimpl.SchemaElementImpl.initTables(SchemaElementImpl.java:216)
	at org.netbeans.modules.hibernate.wizards.support.DBSchemaManager$3.run(DBSchemaManager.java:203)
	at org.netbeans.modules.j2ee.core.api.support.progress.ProgressSupport$ActionInvoker.invokeNextActionsOfSameKind(ProgressSupport.java:270)
	at org.netbeans.modules.j2ee.core.api.support.progress.ProgressSupport$ActionInvoker.access$100(ProgressSupport.java:118)
[catch] at org.netbeans.modules.j2ee.core.api.support.progress.ProgressSupport$ActionInvoker$1.run(ProgressSupport.java:159)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1418)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1957)






java.sql.SQLException: ORA-01000: maximum open cursors exceeded
	at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:134)
	at oracle.jdbc.ttc7.TTIoer.processError(TTIoer.java:289)
	at oracle.jdbc.ttc7.Oopen.receive(Oopen.java:120)
	at oracle.jdbc.ttc7.TTC7Protocol.open(TTC7Protocol.java:586)
	at oracle.jdbc.driver.OracleStatement.<init>(OracleStatement.java:385)
	at oracle.jdbc.driver.OracleStatement.<init>(OracleStatement.java:413)
	at oracle.jdbc.driver.OraclePreparedStatement.<init>(OraclePreparedStatement.java:119)
	at oracle.jdbc.driver.OraclePreparedStatement.<init>(OraclePreparedStatement.java:92)
	at oracle.jdbc.driver.OracleConnection.privatePrepareStatement(OracleConnection.java:950)
	at oracle.jdbc.driver.OracleConnection.prepareStatement(OracleConnection.java:802)
	at org.netbeans.modules.dbschema.jdbcimpl.ViewDependency.getOraclePKTable(ViewDependency.java:106)
	at org.netbeans.modules.dbschema.jdbcimpl.ViewDependency.constructPK(ViewDependency.java:85)
	at org.netbeans.modules.dbschema.jdbcimpl.SchemaElementImpl.initViews(SchemaElementImpl.java:489)
	at org.netbeans.modules.dbschema.jdbcimpl.SchemaElementImpl.initTables(SchemaElementImpl.java:320)
	at org.netbeans.modules.dbschema.jdbcimpl.SchemaElementImpl.initTables(SchemaElementImpl.java:216)
	at org.netbeans.modules.hibernate.wizards.support.DBSchemaManager$3.run(DBSchemaManager.java:203)
	at org.netbeans.modules.j2ee.core.api.support.progress.ProgressSupport$ActionInvoker.invokeNextActionsOfSameKind(ProgressSupport.java:270)
	at org.netbeans.modules.j2ee.core.api.support.progress.ProgressSupport$ActionInvoker.access$100(ProgressSupport.java:118)
	at org.netbeans.modules.j2ee.core.api.support.progress.ProgressSupport$ActionInvoker$1.run(ProgressSupport.java:159)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1418)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1957)
Comment 4 Jiri Rechtacek 2010-07-13 14:42:59 UTC
Once again, I need to know which Oracle JDBC driver did you use. Thanks
Comment 5 esmithbss 2010-07-14 06:24:06 UTC
I'm using the ojdbc14.jar file for Oracle 10g 10.1.0.5 (downloadable from http://www.oracle.com/technology/software/tech/java/sqlj_jdbc/htdocs/jdbc101040.html)
Comment 6 Jiri Rechtacek 2010-07-14 11:37:17 UTC
That's could be a reason why IDE using this driver fails. ojdbc14 driver is designed for JDK1.4 (different feature set than JDK1.6 which contains newer JDBC4.0). Try to use JDBC driver ojdbc6.jar, I download from 
http://www.oracle.com/technology/software/tech/java/sqlj_jdbc/htdocs/jdbc_111060.html and let me know if it helps. Thanks
Comment 7 esmithbss 2010-07-14 16:54:58 UTC
Unfortunately,  due to corporate policy, we are required to use the ojdbc14.jar as the other has not passed security testing yet.

If this is an issue with versions, then there should be a message to the user that they need to upgrade their driver when establishing the connection, or the capability should be disabled for given connections.
Comment 8 Jiri Rechtacek 2011-10-26 14:21:14 UTC
No more similar reports from recent days, seems all upgraded to newly version of driver.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo