Bug 188183 - "application crashed" after cygwin update
"application crashed" after cygwin update
Status: RESOLVED INCOMPLETE
Product: cnd
Classification: Unclassified
Component: Debugger
6.x
PC Solaris
: P3 (vote)
: TBD
Assigned To: Egor Ushakov
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-29 07:03 UTC by Egor Ushakov
Modified: 2011-01-21 13:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
gdblog (3.74 KB, text/plain)
2010-06-29 07:05 UTC, Egor Ushakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Egor Ushakov 2010-06-29 07:03:55 UTC
from user report:

Hi, I've been using netbeans 6.8 and recently upgraded cygwin.  Gcc is 4.3.4 and gdb is 6.8 and I noticed after the upgrade I could no longer run an app in debug mode - it hangs for a while, then a pop up announces "application crashed".  I can run the application inside or outside of netbeans and then attach the debugger and that works.  Tried 6.9 but that didn't change anything.  If I go to Tools->Options->C/C++ and check versions, they come up ok.
...
Thanks, as I mentioned I tried 6.9 to no avail.  Just double checked by setting up a very basic c++ static lib with an app to drive and no luck - I get "application crashed" again.  Thing is, netbeans 6.8 was working fine for many months and it wasn't until I recently upgraded cygwin that debugging broke (inside netbeans, as I mentioned I can still run an app and attach the debugger in netbeans, set breakpoints, step into/over, etc.)  I believe its something related to firing the terminal on start up - it flashes, but I can't read what it says, if anything and then I get the pop up indicating the crash after some delay (~10-15 seconds).   I get the same complaint in the gdb file as posted below.
Comment 1 Egor Ushakov 2010-06-29 07:05:09 UTC
Created attachment 100473 [details]
gdblog
Comment 2 soldatov 2010-07-05 09:02:50 UTC
Hm. I installed latest cygwin and in Welcome project I see "_fu0___ZSt4cout" and "_fu2___ZSt4cout" in call stack instead of main().

$ gdb ./dist/Debug/Cygwin_4.x-Windows/welcome_1.exe
GNU gdb 6.8.0.20080328-cvs (cygwin-special)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-cygwin"...
(gdb) b main
Breakpoint 1 at 0x4011bb: file welcome.cc, line 32.
(gdb) r
Starting program: /cygdrive/c/Documents and Settings/tester/My Documents/NetBean
sProjects/Welcome_1/dist/Debug/Cygwin_4.x-Windows/welcome_1.exe
[New thread 2856.0xb5c]
[New thread 2856.0x2e4]

Breakpoint 1, main (argc=1, argv=0x6aa298) at welcome.cc:32
32      int main(int argc, char**argv) {
(gdb) where
#0  main (argc=1, argv=0x6aa298) at welcome.cc:32
(gdb) n
34          std::cout << "Welcome ..." << std::endl;
(gdb) where
#0  main (argc=1, argv=0x6aa298) at welcome.cc:34
(gdb) n
Welcome ...
37          if (argc > 1) {
(gdb) where
#0  _fu0___ZSt4cout () at welcome.cc:37
(gdb) n
44          return 0;
(gdb) where
#0  _fu2___ZSt4cout () at welcome.cc:44
(gdb)
Comment 3 Egor Ushakov 2010-12-13 18:24:26 UTC
Valery, can you check the issue in the new debugger infrastructure?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo