Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 188086 - Progress bar indicating process is started is not always removed on process termination
Progress bar indicating process is started is not always removed on process t...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: execution
7.0
PC All
: P3 (vote)
: 6.x
Assigned To: Andrew Krasny
issues@cnd
691_late_review_request 69patch1-veri...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-25 08:48 UTC by Andrew Krasny
Modified: 2010-07-07 14:06 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Patch for 6.9.1 branch (4.63 KB, patch)
2010-06-28 17:08 UTC, Andrew Krasny
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Krasny 2010-06-25 08:48:49 UTC
This IZ is about comment #2 from Bug 187144 (Process is not terminated by Stop button in Output tab). Actually in the described case process is terminated, but progress bar still visible and, moreover, cannot be stopped/removed.
Comment 1 Andrew Krasny 2010-06-25 08:57:09 UTC
The problem is in unhandled exception. 

Fixes for this are:

http://hg.netbeans.org/cnd-main/rev/854394ae725e
http://hg.netbeans.org/cnd-main/rev/4a611af85826
Comment 2 Andrew Krasny 2010-06-25 09:04:36 UTC
Alexander, 

should we try to propagate these fixes to 6.9.1?
Comment 3 Alexander Pepin 2010-06-28 09:49:42 UTC
I believe the fix worths including into 6.9.1 as it can happen on any remote platform and remote development now is very important.
Comment 4 Andrew Krasny 2010-06-28 16:18:13 UTC
Provided changesets cannot be easily transplanted to the 6.9.1 branch. This is because changes were made in cnd-main before the fix in affected files... 

I will prepare a separate 'hot fix' for 6.9.1 branch...
Comment 5 Andrew Krasny 2010-06-28 17:08:35 UTC
Created attachment 100465 [details]
Patch for 6.9.1 branch
Comment 6 Andrew Krasny 2010-06-28 17:10:11 UTC
A patch for 6.9.1 branch is attached.
Comment 7 Alexander Pepin 2010-06-28 17:57:30 UTC
verified in NetBeans IDE 6.9.1 Dev build 201006272301 with replaced jar files provided by developers.
Comment 8 rbalada 2010-06-28 18:11:03 UTC
Guys,

nominations for release691 repo have been closed. Please discuss with release boss if you can integrate your change in release691 repository.

Thanks,
Your GateKeeper
Comment 9 Alexander Pepin 2010-06-29 09:18:29 UTC
This fix is a fixed part of bug #187144 which was nominated  for 6.9.1 but could not be fixed completely. Integration is approved by Martin Ryzl.
Rudolf, please port the fix into 6.9.1.
Comment 10 pgebauer 2010-06-30 12:34:33 UTC
The fix has been ported into the release691 brach
http://hg.netbeans.org/release691/rev/49b446af2473
Comment 11 Alexander Pepin 2010-07-07 14:06:57 UTC
verified in 6.9.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo