Bug 187989 - Cpu load 100% (50% dual-core) after formatting any code or idle state.
Cpu load 100% (50% dual-core) after formatting any code or idle state.
Status: RESOLVED DUPLICATE of bug 188155
Product: php
Classification: Unclassified
Component: Editor
6.x
PC Windows 7 x64
: P2 (vote)
: 7.0
Assigned To: rmatous
issues@php
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-23 09:57 UTC by valCooL
Modified: 2010-07-16 13:45 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (167.02 KB, application/octet-stream)
2010-06-23 09:57 UTC, valCooL
Details
ide log output (29.82 KB, text/plain)
2010-06-23 09:58 UTC, valCooL
Details
Another snapshot from a PHP user, when the cpu is consumed too much. (36.51 KB, application/octet-stream)
2010-06-28 13:43 UTC, Petr Pisl
Details
thread dumps for compartibility mode (322.96 KB, application/zip)
2010-06-29 07:44 UTC, valCooL
Details
30-06 thread dump (145.15 KB, application/zip)
2010-06-30 10:31 UTC, valCooL
Details

Note You need to log in before you can comment on or make changes to this bug.
Description valCooL 2010-06-23 09:57:40 UTC
Created attachment 100355 [details]
thread dump

NetBeans IDE goes into continuous CPU load randomly when trying to do code formatting operation on Win 7 x64. After that - code formatting and navigator doesn't works at all, showing continuous business.
External src scans, SVN & etc is disabled.
Tried to run app with administrator privileges and in compartibility mode - doesn't solves a problem.
Comment 1 valCooL 2010-06-23 09:58:33 UTC
Created attachment 100356 [details]
ide log output
Comment 2 valCooL 2010-06-23 10:32:32 UTC
also same situation with auto completion, somehow it hangs ide on 100% load, then showing constant 'please wait' popup when toggling.
Comment 3 Peter Pis 2010-06-24 06:52:41 UTC
Could you please take and attach 2-3 thread dumps while running into this? Thanks.
http://wiki.netbeans.org/GenerateThreadDump
Comment 4 Tomas Mysik 2010-06-28 08:03:44 UTC
Parsing & indexing, have a look at the snapshot.
Comment 5 Petr Pisl 2010-06-28 13:43:56 UTC
Created attachment 100458 [details]
Another snapshot from a PHP user, when the cpu is consumed too much. 

The snapshot is from NB 6.9.
Comment 6 rmatous 2010-06-28 14:03:14 UTC
is it possible for me to have reproducible case(the project or artificial extracted as simple as possible code) where could I reproduce? If so, then I hope I'm ready to fix it pretty soon, thanks
Comment 7 valCooL 2010-06-29 07:44:32 UTC
Created attachment 100476 [details]
thread dumps for compartibility mode

(In reply to comment #6)
> is it possible for me to have reproducible case(the project or artificial
> extracted as simple as possible code) where could I reproduce? If so, then I
> hope I'm ready to fix it pretty soon, thanks

Issue stoped reproducing since i disabled all major team features, as svn refresh, also disabled external refresh, disabled spellchecker plugin, spellchecker dictionary plugin, hudson plugin and installed JIRA team plugin. Maybe it's not the reason, just working with other code.
I have another couple of thread dumps of this issue, when tried to work in compartibility mode, so i'll attach it now.
Comment 8 valCooL 2010-06-30 10:31:45 UTC
Created attachment 100515 [details]
30-06 thread dump

reproduced today when _> turned on external php vars autocompletion <_ & tried go to definition of native 'yii framework' method 'getPathOfAlias' on this code. It has pretty much recursion though.

>
>$this->renderFile(Yii::getPathOfAlias('webroot').'/views/system/>eventNotification.php', array(
>                    'event' => $event,
>                    'user' => $user
>                ), true);
>

thread dump attached.
Comment 9 rmatous 2010-07-16 11:35:38 UTC
Duplicate of #188155

*** This bug has been marked as a duplicate of bug 188155 ***
Comment 10 rmatous 2010-07-16 13:45:08 UTC
Fixed in trunk now:
http://hg.netbeans.org/web-main/rev/2b54057d9d46

This issue might be also fixed into release 6.9.1, but I need verification that
the fix really helps. Thanks to rogojine I was able to reproduce the never
ending loop, so at least in this usecase this fix works.

Problem description: never ending loop for type inference when e.g. method "a"
calls method "b"  and method "b" calls method "a" (on different types but with
the same name). 

Justification for fixing it into relase 6.9.1:
-many duplicates
-complains about it on forums, blogs
(http://blogs.sun.com/netbeansphp/entry/is_the_ide_slow_send#comments)


For verification use please #2079 build (or newer):
http://bertram.netbeans.org/hudson/job/PHP-build/2079/
(http://bertram.netbeans.org/hudson/job/PHP-build/)

PLEASE VERIFY


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo