Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187910 - AssertionError: org.netbeans.modules.web.project.WebProject violates #185464
AssertionError: org.netbeans.modules.web.project.WebProject violates #185464
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Web Project
6.x
All All
: P3 (vote)
: 7.0
Assigned To: David Konecny
issues@javaee
EXCEPTIONS_REPORT 69patch1-verified
:
: 185464 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-21 21:46 UTC by David Konecny
Modified: 2010-07-26 20:26 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (7.75 KB, text/plain)
2010-06-21 21:46 UTC, David Konecny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Konecny 2010-06-21 21:46:02 UTC
Build: NetBeans IDE Dev (Build 100616-e0ee2491f1a5)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Linux

User Comments:
dkonecny: happened after IDE started. have several project types opened. mostly maven ones.

GUEST: startup




Stacktrace: 
java.lang.AssertionError: org.netbeans.modules.web.project.WebProject violates #185464
   at org.netbeans.modules.projectapi.AuxiliaryConfigImpl$1.run(AuxiliaryConfigImpl.java:86)
   at org.netbeans.modules.projectapi.AuxiliaryConfigImpl$1.run(AuxiliaryConfigImpl.java:82)
   at org.openide.util.Mutex.readAccess(Mutex.java:288)
   at org.netbeans.modules.projectapi.AuxiliaryConfigImpl.getConfigurationFragment(AuxiliaryConfigImpl.java:82)
   at org.netbeans.modules.j2ee.common.project.ui.AbstractLogicalViewProvider.isVisualWebLegacyProject(AbstractLogicalViewProvider.java:751)
   at org.netbeans.modules.j2ee.common.project.ui.AbstractLogicalViewProvider.hasBrokenDataSource(AbstractLogicalViewProvider.java:771)
Comment 1 David Konecny 2010-06-21 21:46:06 UTC
Created attachment 100290 [details]
stacktrace
Comment 2 Jesse Glick 2010-06-21 21:53:33 UTC
project.getLookup() => null, apparently.
Comment 3 David Konecny 2010-06-22 23:13:20 UTC
6278ee01aff9
Comment 4 Jesse Glick 2010-06-22 23:15:03 UTC
6.9.1_CANDIDATE?
Comment 5 David Konecny 2010-06-22 23:28:21 UTC
I was wondering about that but I thought it has just a few exception reports so perhaps it does not happen that often? On the other hand fixing it in 691 does not do any harm. :-)
Comment 6 Jesse Glick 2010-06-23 00:41:17 UTC
Add in reports from bug #185464 and its duplicates and you get another 15.
Comment 7 rbalada 2010-06-23 22:31:27 UTC
Please verify bugfix for this bug ASAP, so it can be integrated into release691
repository.

Thanks,
-R
Comment 8 Jesse Glick 2010-06-23 23:31:00 UTC
Where is the fix? Not in main-silver, not in jet-main.
Comment 9 rbalada 2010-06-25 06:16:32 UTC
Last chance for inclusion in release691.

Please verify within 4 hours from now, since I have got limited time to transplant remaining bugfixes into release691 repository. June 25, 1 PM Prague time is my deadline. After that time, please do also the transplant/porting work if you want to include it.

Thank you for understanding,
-R
Comment 10 David Konecny 2010-06-27 20:37:34 UTC
I had Thu and Fri off. The fix was pushed now.
Comment 11 rbalada 2010-06-28 00:54:57 UTC
Davide,

please verify A.S.A.P.

Dik,
-R
Comment 12 Tomas Mysik 2010-06-28 08:21:28 UTC
Patch seems to be OK IMHO. For long-term solution, leaking of this from constructor should be avoided, if possible.
Comment 13 rbalada 2010-06-28 09:47:04 UTC
main #6278ee01aff9 transplanted to release691 #741a8d67f754
Comment 14 Jaroslav Pospisil 2010-06-28 11:03:19 UTC
Can't reproduce anymore - seems to be OK now.
Comment 15 Jesse Glick 2010-07-26 20:26:28 UTC
*** Bug 185464 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo