Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187886 - Add friend dependency
Add friend dependency
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: XML Multiview
6.x
All All
: P2 (vote)
: 7.0
Assigned To: Milan Kuchtiak
issues@xml
69patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-21 12:11 UTC by Radko Najman
Modified: 2010-07-09 08:41 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Radko Najman 2010-06-21 12:11:28 UTC
Please add org.netbeans.modules.javame.bdj.bdjo.project module as a friend of
XML Multiview module (org-netbeans-modules-xml-multiview.jar).

This fix is important for Java ME SDK 3.1 release and is requested for NetBeans
6.9.1.
Comment 1 Milan Kuchtiak 2010-06-21 12:34:54 UTC
Fixed:
http://hg.netbeans.org/web-main/rev/8d71d3e5edc5

Reporter, please verify the fix to allow integration into 6.9.1.
Comment 2 Radko Najman 2010-06-21 12:56:54 UTC
Verified.
Comment 3 rbalada 2010-06-21 13:20:40 UTC
transplanted to release691 #2fd5f8b61460
Comment 4 Quality Engineering 2010-06-22 03:19:39 UTC
Integrated into 'main-golden', will be available in build *201006220001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/8d71d3e5edc5
User: mkuchtiak@netbeans.org
Log: #187886: adding friend module to xml.multiview
Comment 5 Martin Fousek 2010-07-09 08:32:12 UTC
Verified added friend in release691 repository. Yesterday I also checked that daily build of Java ME SDK 3.1 can be added as a platform into NetBeans IDE 6.9.1 Dev (Build 201007062301, but not sure if it wouldn't be successful without added friend as well. Anyway, friend was verified in rep.
Comment 6 martin_sladecek 2010-07-09 08:41:49 UTC
This is not needed for adding Java ME SDK 3.1 as a platform. Java ME SDK 3.1 has it's own set of Netbeans plugins and module org.netbeans.modules.javame.bdj.bdjo.project needs to be friend of the XML Multiview module to work.
Adding Java ME SDK 3.1 as a platform should be successful also without this modification, of course. :-)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo