Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187867 - [69cat] IllegalStateException: attempted model write without invoking startTransaction
[69cat] IllegalStateException: attempted model write without invoking startTr...
Status: RESOLVED DUPLICATE of bug 181290
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P1 (vote)
: TBD
Assigned To: David Simonek
issues@projects
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-21 08:00 UTC by cameronr
Modified: 2010-07-15 14:32 UTC (History)
17 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.58 KB, text/plain)
2010-06-21 08:00 UTC, cameronr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cameronr 2010-06-21 08:00:40 UTC
This bug was originally marked as duplicate of bug 181290, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 6.9 (Build 201006101454)
VM: Java HotSpot(TM) Client VM, 16.0-b13, Java(TM) SE Runtime Environment, 1.6.0_18-b07
OS: Windows XP

User Comments:
GUEST: adding a maven library dependency

GUEST: adding a dependency to my project

FrantaM: Addind a dependency to maven project through Add dependency dialog.

kawazu428: removed a dependency from a maven2 pom.xml ...

tim_sa: In a maven netbeans Platform Application ,right clicked libraries add new dependencies, and selected a module as a dependcy

madhurtanwani: Everytime I add a dependency to the project (not via modifying pom, but using the UI) this error is seen

artisan: Adding commons-lang-2.4 to the maven test dependencies.

GUEST: Adding library to a project. Did a manual maven install into the local maven repository. Updated index in Netbeans and tried adding library to my project.

FrantaM: Added a dependency through Add dependency... dialog with no version specified. The dependency was added correctly.

GUEST: adding test library

aldobrucale: Adding a maven dependency

GUEST: Add maven dependencies, that do not exists for futher manual instalation

jsbboss: Including a maven depency by selecting Open Projects, to the Libraries in my project

GUEST: Adding a dependency after adding a <repository> tag in the pom.xml of a fresh JEE5 Webapp.

GUEST: Adding new netbeans platform module to 
Comment 1 cameronr 2010-06-21 08:00:47 UTC
Created attachment 100260 [details]
stacktrace
Comment 2 Sergey Lunegov 2010-06-21 11:23:52 UTC
reassign to maven
Comment 3 Exceptions Reporter 2010-07-02 13:47:26 UTC
This bug already has 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=170827
Comment 4 Exceptions Reporter 2010-07-02 13:50:25 UTC
This bug already has 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=170827
Comment 5 Antonin Nebuzelsky 2010-07-09 12:38:53 UTC
IllegalStateException: attempted model write without invoking startTransaction
 at o.n.m.xml.xam.AbstractModel.validateWrite(AbstractModel.java:469)
 at o.n.m.xml.xam.AbstractModel.rollbackTransaction(AbstractModel.java:428)
 at o.n.m.maven.model.Utilities.performPOMModelOperations(Utilities.java:346)

The rollback here is called only after model.isIntransaction() is true. Does it mean that some other way of verifying that transaction can be rollbacked needs to be used?

Nikita, can you advise? Thanks.
Comment 6 Jesse Glick 2010-07-15 14:32:48 UTC
I think already fixed, either by bug #181290 or bug #188363.

*** This bug has been marked as a duplicate of bug 181290 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo