Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187758 - NullPointerException at org.netbeans.modules.cnd.api.model.services.CsmVirtualInfoQuery.methodEquals
NullPointerException at org.netbeans.modules.cnd.api.model.services.CsmVirtua...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Alexander Simon
issues@cnd
EXCEPTIONS_REPORT, 69patch1-verified
:
: 188218 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 22:18 UTC by tbrunhoff
Modified: 2010-07-07 14:02 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.55 KB, text/plain)
2010-06-17 22:18 UTC, tbrunhoff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tbrunhoff 2010-06-17 22:18:36 UTC
Build: NetBeans IDE Dev (Build 201006130001)
VM: Java HotSpot(TM) 64-Bit Server VM, 16.0-b13, Java(TM) SE Runtime Environment, 1.6.0_18-b07
OS: Linux

User Comments:
tbrunhoff: editing, soon after restarting ide, after updating to current dev.




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.cnd.api.model.services.CsmVirtualInfoQuery.methodEquals(CsmVirtualInfoQuery.java:107)
   at org.netbeans.modules.cnd.api.model.services.CsmVirtualInfoQuery.access$100(CsmVirtualInfoQuery.java:68)
   at org.netbeans.modules.cnd.api.model.services.CsmVirtualInfoQuery$Empty.processClass(CsmVirtualInfoQuery.java:156)
   at org.netbeans.modules.cnd.api.model.services.CsmVirtualInfoQuery$Empty.isVirtual(CsmVirtualInfoQuery.java:145)
   at org.netbeans.modules.cnd.navigation.overrides.ComputeAnnotations.computeAnnotation(ComputeAnnotations.java:114)
   at org.netbeans.modules.cnd.navigation.overrides.ComputeAnnotations.computeAnnotations(ComputeAnnotations.java:99)
Comment 1 tbrunhoff 2010-06-17 22:18:40 UTC
Created attachment 100187 [details]
stacktrace
Comment 2 Alexander Simon 2010-06-18 04:47:04 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/0f71a3147d8a
Comment 3 rbalada 2010-06-18 06:24:49 UTC
I saw changeset release691 #b76318567dcb

Please add keyword 6.9.1_CANDIDATE and mark bugs VERIFIED before integrating into release691 repository.

Thanks,
-R
Comment 4 Quality Engineering 2010-06-19 03:38:33 UTC
Integrated into 'main-golden', will be available in build *201006190001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0f71a3147d8a
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed BZ#187758 NullPointerException at org.netbeans.modules.cnd.api.model.services.CsmVirtualInfoQuery.methodEquals
Comment 5 Alexander Pepin 2010-06-21 12:00:23 UTC
can not reproduce in the trunk build 2010061 so that I mark the bug as verified
Comment 6 Alexander Pepin 2010-06-21 12:02:02 UTC
tbrunhoff, please confirm the the bug has been fixed.
Comment 7 tbrunhoff 2010-06-21 15:57:52 UTC
I cannot reliably confirm whether this is fixed or not, because it was a one time incident for which I don't know the parameters that might repeat it.

If you see no more reports with this stack trace from me, you may assume that my computer thinks it is fixed :-)
Comment 8 Vladimir Kvashin 2010-07-03 09:33:14 UTC
*** Bug 188218 has been marked as a duplicate of this bug. ***
Comment 9 Alexander Pepin 2010-07-07 14:02:20 UTC
verified in 6.9.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo