Bug 187749 - Installation fails with non-zero error code returned by unpack200
Installation fails with non-zero error code returned by unpack200
Status: RESOLVED DUPLICATE of bug 117334
Product: installer
Classification: Unclassified
Component: NBI
6.x
PC Windows XP
: P1 (vote)
: TBD
Assigned To: dlipin
issues@installer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 19:14 UTC by griff4987
Modified: 2010-06-18 17:18 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
zip of nbi taken after installer has exited. (230.74 KB, application/octet-stream)
2010-06-17 19:14 UTC, griff4987
Details
Output of tasklist (21.19 KB, text/plain)
2010-06-18 11:48 UTC, griff4987
Details

Note You need to log in before you can comment on or make changes to this bug.
Description griff4987 2010-06-17 19:14:42 UTC
Created attachment 100182 [details]
zip of nbi taken after installer has exited.

System is Windows XP, SP3, 4GB Memory, 27GB disk space free. Java SDK 1.6_b20 installed. Symantic Endpoint Protection is installed, but disabled.

Started install of NetBeans 6.9 Java product for Windows. Installation appears `normal` through Summary page. Click on button, and installation proceeds. Setup Complete dialog shows, but with a message in red:

Installation of Base IDE, Java SE, Java Web and EE, Java ME, Java Card (TM) 3 Connected, Groovy, Features on Demand was not completed.

Try to run installer again or consult the installation log file for more details:
<path>

Finish button appears lower right, clicking it ends install process.

No entries created in start menu. Glassfish appears to be installed. NetBeans directory appears to be very incomplete (platform/modules/locale directories only)

zip of nbi directory attached.
Comment 1 dlipin 2010-06-17 19:40:07 UTC
Do you have Logitech QuickCam service (lvprcsrv.exe) running?
Or any antivirus/firewall/monitoring tool?
Comment 2 griff4987 2010-06-17 20:21:27 UTC
Symantec Endpoint Protection was installed, but disabled from 'front panel' control. Logitech Video Com Service was installed and running, lvprcsrv.exe was running.

Just repeated experiment with all Symantec-related services and all Logitech-related serives stopped from the service control panel, and lvprcsrv.exe stopped via Task Manager. Same result.

I suspect you're on the right track, I'll experiment more.
Comment 3 dlipin 2010-06-18 10:28:49 UTC
> I suspect you're on the right track, I'll experiment more.

Thanks a lot. We actually saw such influence (bad exit code returned by unpack200) by lvprcsrv.exe process so it was the first thing I thought about.
Likely there are another tools that cause the similar behaviour. 
It would be great if you could identify it in your environment - e.g. by killing each unneeded process one by one (or a bunch) any rerunning the installer after that - and let us know the name of the process.

BTW, could you please run
C:\WINDOWS\system32\tasklist.exe  /V > out.txt
and attach out.txt to the issue? I can take a look at the list of running programs to help identify the problematic one.

Thanks.
Comment 4 griff4987 2010-06-18 11:48:42 UTC
Created attachment 100201 [details]
Output of tasklist

Interesting, unpack200 has never exited. I'll retry after killing it.
Comment 5 griff4987 2010-06-18 11:50:04 UTC
Tried to terminate unpack200 and it would not terminate. Will reboot.
Comment 6 griff4987 2010-06-18 12:29:47 UTC
OK, disabled Symantic and Logitech services and did a reboot. Inspected running process list using task manager and nothing appearing to be related to either products appeared to be running. No instances of update200 were running either. Did an installation and it worked fine.

My guess is that your initial response was right - update200 is not happy when the logitech application is running.
Comment 7 griff4987 2010-06-18 12:49:12 UTC
I'll buy that this is a dup of 117334, but there's nothing in the Release Notes for 6.9 about it....so I'll let you resolve it :->
Comment 8 dlipin 2010-06-18 17:18:15 UTC
> I'll buy that this is a dup of 117334, but there's nothing in the Release Notes
for 6.9 about it....so I'll let you resolve it :->

Yes, we don't have any info on that in release notes but do have in installation instructions :)
http://www.netbeans.org/community/releases/69/install.html

*** This bug has been marked as a duplicate of bug 117334 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo