Bug 187695 - php short tag formatting is not working properly
php short tag formatting is not working properly
Status: RESOLVED DUPLICATE of bug 187309
Product: php
Classification: Unclassified
Component: Formatting & Indentation
6.x
PC Windows XP
: P1 (vote)
: 6.x
Assigned To: Petr Pisl
issues@php
http://forums.netbeans.org/topic26792...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 04:39 UTC by narcom
Modified: 2010-06-18 09:49 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description narcom 2010-06-17 04:39:40 UTC
look at this post http://forums.netbeans.org/topic26792.html user marko5

When I autoformat the following code :
Code:
<a href="<?=$ahref?>" class='next'>Next Page &gt;&gt;</a>

it becomes :
Code:
<a href="<?=$ahref
        ?>" class='next'>Next Page &gt;&gt;</a>


if I change the line to <? echo instead of the <? = like below, the line bread does not happen.
Code:
<a href="<? echo $ahref; ?>" class='next'>Next Page &gt;&gt;</a>

so It is absolutely not possible to format php templates whit short open tags
Comment 1 Petr Pisl 2010-06-18 09:49:46 UTC
This issue I fixed last week. See issue #187309. It wasn't possible to deliver the fix into NB 6.9, it's available in dev builds and also is already transplanted to the patch release.

*** This bug has been marked as a duplicate of bug 187309 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo