Bug 187595 - Recognize ${project.build.directory}/generated-test-sources/*
Recognize ${project.build.directory}/generated-test-sources/*
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: 7.1
Assigned To: Jesse Glick
issues@projects
: PLAN
: 170700 200524 203623 (view as bug list)
Depends on:
Blocks: 191864
  Show dependency treegraph
 
Reported: 2010-06-15 12:15 UTC by schulte2004
Modified: 2011-10-29 01:16 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description schulte2004 2010-06-15 12:15:36 UTC
Currently the IDE scans ${project.build.directory}/generated-sources/* directories for sources. Please also support generated test sources in ${project.build.directory}/generated-test-sources/* directories. See <http://mojo.codehaus.org/jaxb2-maven-plugin/testXjc-mojo.html#outputDirectory> for example.
Comment 1 hup 2010-07-23 21:18:38 UTC
Please add support for generated-test-sources or please tell any work around because this feature prevent me from work with auto generated classes used for unit testing :(
Comment 2 Jesse Glick 2010-07-23 21:39:43 UTC
I think a defect that it does not do so already.
Comment 3 Jesse Glick 2011-06-01 18:10:56 UTC
*** Bug 170700 has been marked as a duplicate of this bug. ***
Comment 4 Jesse Glick 2011-06-01 19:14:30 UTC
core-main #c531f935e5d0
Comment 5 Quality Engineering 2011-06-02 20:05:53 UTC
Integrated into 'main-golden', will be available in build *201106021001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/c531f935e5d0
User: Jesse Glick <jglick@netbeans.org>
Log: #187595: Recognize ${project.build.directory}/generated-test-sources/*
Comment 6 Jesse Glick 2011-08-01 13:09:35 UTC
*** Bug 200524 has been marked as a duplicate of this bug. ***
Comment 7 Jesse Glick 2011-10-29 01:16:08 UTC
*** Bug 203623 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo