Bug 187561 - When Read-Only File is changed to Writable, the Gray Background stays.
When Read-Only File is changed to Writable, the Gray Background stays.
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
6.x
All All
: P1 with 2 votes (vote)
: 7.0
Assigned To: Miloslav Metelka
issues@editor
: 70_HR_FIX, REGRESSION
: 187733 (view as bug list)
Depends on:
Blocks: 196677
  Show dependency treegraph
 
Reported: 2010-06-14 18:09 UTC by rpattersoncc
Modified: 2011-04-06 14:08 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rpattersoncc 2010-06-14 18:09:09 UTC
Product Version = NetBeans IDE 6.9 RC2 (Build 201005312001)
Operating System = Windows Vista version 6.0 running on x86
Java; VM; Vendor = 1.6.0_20
Runtime = Java HotSpot(TM) Client VM 16.3-b01

When a file is read-only and is opened, the background is gray.  If the file is changed to writable, the background is still gray.  The file must be reopened to change back to white.
Comment 1 Peter Pis 2010-06-15 08:06:17 UTC
Please evaluate.
Comment 2 Jaroslav Tulach 2010-06-15 20:41:29 UTC
I guess you mean background in editor.
Comment 3 Vitezslav Stejskal 2010-06-18 08:30:19 UTC
*** Bug 187733 has been marked as a duplicate of this bug. ***
Comment 4 Vladimir Kvashin 2011-02-24 11:34:16 UTC
Is there any possibility to fix this in 7.0?
Comment 5 Miloslav Metelka 2011-02-28 15:14:31 UTC
AFAIK there's no listener for changes in modifiability of the document so we will have to do some kind of periodic checks for modifiability (likely just for the file being edited) preferably in post-7.0.
Comment 6 Vladimir Kvashin 2011-03-01 15:09:10 UTC
I thought that the event is fired in 
FileObj.refreshImpl (FileObj.java:302):
fireFileAttributeChangedEvent("DataEditorSupport.read-only.refresh", null, null);
?
Comment 7 Miloslav Metelka 2011-03-31 00:39:04 UTC
http://hg.netbeans.org/jet-main/rev/54a582d206fa
Comment 8 Vladimir Voskresensky 2011-03-31 05:54:23 UTC
Mila, it is a regression comparing to 6.9.1 and in context for our remote mode (when all files are read only until connection is established) it is rather problematic for user.
Let me rise priority because of regression.
Comment 9 Miloslav Metelka 2011-03-31 16:20:40 UTC
In case it's really important for you to have it in 7.0 then please test the fix first and then raise it to P1 so that I can consider porting it to 7.0 RC2. The fix is IMHO not risky and if it's not too late then we should possibly be able to port it.
Comment 10 Vladimir Voskresensky 2011-03-31 16:38:03 UTC
verified in trunk for local and remote file systems
Comment 11 Miloslav Metelka 2011-04-01 07:50:46 UTC
Integrated into release70:
54a582d206fa transplanted to f850e2b05974
Comment 12 Quality Engineering 2011-04-01 08:40:28 UTC
Integrated into 'main-golden', will be available in build *201104010400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/54a582d206fa
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #187561 - When Read-Only File is changed to Writable, the Gray Background stays.
Comment 13 Tomas Danek 2011-04-06 14:08:24 UTC
verified 
Product Version: NetBeans IDE 7.0 RC2 (Build 201104060000)
Java: 1.6.0_24; Java HotSpot(TM) 64-Bit Server VM 19.1-b02-334
System: Mac OS X version 10.6.7 running on x86_64; MacRoman; en_US (nb)
Userdir: /Users/tomas/.netbeans/7.0rc2


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo