Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187465 - NullPointerException at org.netbeans.modules.php.editor.PHPCodeCompletion.autoCompleteClassMembers
NullPointerException at org.netbeans.modules.php.editor.PHPCodeCompletion.aut...
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Editor
6.x
All All
: P3 (vote)
: 7.0
Assigned To: rmatous
issues@php
EXCEPTIONS_REPORT, 69patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 08:21 UTC by jonavogt
Modified: 2010-07-08 15:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.02 KB, text/plain)
2010-06-11 08:21 UTC, jonavogt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jonavogt 2010-06-11 08:21:15 UTC
This issue was reported manually by jonavogt.
It already has 4 duplicates 


Build: NetBeans IDE Dev (Build 2010-06-11_09-03-56 )
VM: OpenJDK Client VM, 14.0-b16, OpenJDK Runtime Environment, 1.6.0_18-b18
OS: Linux

User Comments:
jonavogt: Typed after object operator (code completion?)

jonavogt: Codecompletion




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.php.editor.PHPCodeCompletion.autoCompleteClassMembers(PHPCodeCompletion.java:719)
   at org.netbeans.modules.php.editor.PHPCodeCompletion.complete(PHPCodeCompletion.java:354)
   at org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery.addCodeCompletionItems(GsfCompletionProvider.java:610)
   at org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery.resolveCompletion(GsfCompletionProvider.java:598)
   at org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery.access$400(GsfCompletionProvider.java:246)
   at org.netbeans.modules.csl.editor.completion.GsfCompletionProvider$JavaCompletionQuery$1.run(GsfCompletionProvider.java:336)
Comment 1 jonavogt 2010-06-11 08:21:19 UTC
Created attachment 100002 [details]
stacktrace
Comment 2 jonavogt 2010-06-11 08:24:03 UTC
maybe related to bug #187431 ?
Comment 3 rmatous 2010-06-11 08:53:04 UTC
http://hg.netbeans.org/web-main/rev/88b6332c9405

indirectly related to bug #187431?
Comment 4 rmatous 2010-06-11 09:15:58 UTC
this problem doesn't exists in 6.9, I think. Needs to be fixed in 6.9.1 just in
case if #186858 should be transplanted into 6.9.1 also
Comment 5 Quality Engineering 2010-06-12 06:51:50 UTC
Integrated into 'main-golden', will be available in build *201006120001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/88b6332c9405
User: Radek Matous <rmatous@netbeans.org>
Log: #187465 - NullPointerException at org.netbeans.modules.php.editor.PHPCodeCompletion.autoCompleteClassMembers
Comment 6 rbalada 2010-06-16 08:57:18 UTC
Please verify bugfix for this bug, so it can be included in release691 repository.

Thanks,
-R
Comment 7 jonavogt 2010-06-16 10:14:34 UTC
Seems to be fixed, yes. Thank you
Comment 8 Petr Blaha 2010-06-17 11:51:53 UTC
verified
Comment 9 rbalada 2010-06-21 14:11:00 UTC
main #88b6332c9405 transplanted to release691 #e16bc8cdccd0
Comment 10 Jaromir Uhrik 2010-07-08 15:17:34 UTC
Unable to reproduce. Verified in the latest 6.9.1 build:
Product Version: NetBeans IDE 6.9.1 Dev (Build 201007062301)
Java: 1.6.0_20; Java HotSpot(TM) 64-Bit Server VM 16.3-b01-279
System: Mac OS X version 10.5.8 running on x86_64; MacRoman; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo