Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187445 - Need a way to log JDI calls
Need a way to log JDI calls
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
69patch1-verified
:
Depends on: 185431
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-10 16:52 UTC by Martin Ryzl
Modified: 2010-07-16 07:41 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Ryzl 2010-06-10 16:52:35 UTC
Need a way to log JDI calls - main goal is to be able to reproduce problems independently of NetBeans. At the moment we need it for stabilization of the debugger with FXJDI but it may be useful also for performance testing.
Comment 1 Martin Entlicher 2010-06-11 13:43:58 UTC
I can add logging to JDI wrapper classes - package org.netbeans.modules.debugger.jpda.jdi.
The logging will work for all JDI methods called through debugger actions and API, with the exception of expression evaluation. If there is a need, it can be extended for the evaluation as well.
But such logging will not work for JDI calls explicitly performed by JavaFX debugger directly on JDI objects. You'd have to add your own logging, specially if you use some javafx-specific JDI extensions.
Comment 2 Martin Entlicher 2010-06-11 13:45:50 UTC
FYI: To log JDWP traffic, you can also use https://jdwpanalyzer.dev.java.net/
Comment 3 Martin Entlicher 2010-06-14 13:54:40 UTC
Logging is added in changeset:   172928:30fc0438629e
http://hg.netbeans.org/main/rev/30fc0438629e
Comment 4 Quality Engineering 2010-06-15 03:26:10 UTC
Integrated into 'main-golden', will be available in build *201006150001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/30fc0438629e
User: mentlicher@netbeans.org
Log: #187445 - Allow logging of JDI method calls.
Comment 5 rbalada 2010-06-16 08:57:05 UTC
Please verify bugfix for this bug, so it can be included in release691 repository.

Thanks,
-R
Comment 6 Petr Blaha 2010-06-17 11:51:52 UTC
verified
Comment 7 rbalada 2010-06-21 14:57:34 UTC
It looks like merge conflict for merging the changeset main #30fc0438629e into release691 repository.

I've identified dependency on changeset main #df59fa0b7a46, namely change in file debugger.jpda/src/org/netbeans/modules/debugger/jpda/jdi/request/EventRequestManagerWrapper.java

Please let me know the best approach for resolution of this merge conflict.

I've got following options:

#1 Mark issue 185431 with keyword 6.9.1_CANDIDATE and verify it on trunk 

#2 I can do partial port or changeset main #df59fa0b7a46, namely the part in file debugger.jpda/src/org/netbeans/modules/debugger/jpda/jdi/request/EventRequestManagerWrapper.java


Ad #1) I will then transplant whole changeset main #df59fa0b7a46 into release691 repo, what will makes the changeset main #30fc0438629e cleanly applicable on transplant

Ad #2) Partial changeset ports can be dangerous, especially in code clearly marked with comment "// DO NOT MODIFY THIS CODE, GENERATED AUTOMATICALLY"


I need some to bless either of those options or suggest another option.

Thanks,
-R
Comment 8 rbalada 2010-06-22 15:40:56 UTC
I've prepared combined change in branch debugger_ports in release691 repository.
Comment 9 rbalada 2010-06-24 21:58:08 UTC
ported to release691 #e8181c0a7e5d
Comment 10 Marian Mirilovic 2010-07-16 07:31:31 UTC
verified changes integrated into release691 clone


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo