Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187438 - Attempt to open file from MAC OS X Context menu
Attempt to open file from MAC OS X Context menu
Status: RESOLVED DUPLICATE of bug 138943
Product: installer
Classification: Unclassified
Component: Mac Native
6.x
Macintosh (x86) Mac OS X
: P2 with 3 votes (vote)
: TBD
Assigned To: Yulia Novozhilova
issues@installer
:
: 88715 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-10 14:58 UTC by jmcbade
Modified: 2012-12-05 16:55 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jmcbade 2010-06-10 14:58:19 UTC
This behavior is under Snow Leopard 10.6

Selecting a Ruby file with a right click, selecting "Open With" Netbeans 6.9RC2 will not open the file in the IDE.  Using Open File and navigating to it will.
Comment 1 birwel 2010-07-23 07:48:55 UTC
It also happens with the Netbeans PHP package. 
"Open With >> Netbeans" (from finder) feature doesn't work, and so happens when dragging to the dock.

Java installed version is 1.6, and netbeans 6.9 too.
Tried with other Java Apps and the result was the same.
Comment 2 jdc 2010-08-06 16:42:43 UTC
This seems like a duplicate of:

http://netbeans.org/bugzilla/show_bug.cgi?id=88715

Which has been around since 06.
Comment 3 Erno Mononen 2010-08-16 14:31:04 UTC
This is a general issue (not ruby specific as you also noted), but not sure what would be the correct component for this. So I'm assigning this to 'ide' for evaluation.
Comment 4 Peter Pis 2010-08-16 14:45:59 UTC
Please evaluate.
Comment 5 jmcbade 2010-08-16 23:47:37 UTC
Yes,

You are correct, this is not a "Ruby only" issue.  I discovered it first using Ruby.

Seems this is an item that has been omitted for a long time, before this current version.
Comment 6 jdc 2010-08-26 19:04:39 UTC
Be sure to add a vote to this issue as it is highly annoying. Even double clicking a Netbeans controlled file in Finder will not open it in the ide. The only way to open a file with the ide is by using the ides file menu.
Comment 7 Antonin Nebuzelsky 2010-09-15 11:35:46 UTC
*** Bug 88715 has been marked as a duplicate of this bug. ***
Comment 8 Jaroslav Tulach 2010-09-15 16:14:21 UTC
Try calling bin/netbeans --open name-of-the-file.ext from terminal. If that works, the issue is in Mac OS X installer.

PS: I don't have Mac to try it myself. CCing Tomáš to help me, if he finds some time.
Comment 9 jdc 2010-09-15 16:29:07 UTC
(In reply to comment #8)
> Try calling bin/netbeans --open name-of-the-file.ext from terminal. If that
> works, the issue is in Mac OS X installer.
> 
> PS: I don't have Mac to try it myself. CCing Tomáš to help me, if he finds some
> time.

I ran this command:

/Applications/NetBeans/NetBeans\ 6.9.app/Contents/MacOS/netbeans --open file.php

and it successfully opened the file in NetBeans.
Comment 10 lshaner 2010-09-15 16:50:38 UTC
The bug that I reported on 88715 is specific to .xml files.
Netbeans opens, but I am not dropped into the .xml viewer with the file loaded.
Comment 11 jdc 2010-09-15 17:02:33 UTC
(In reply to comment #10)
> The bug that I reported on 88715 is specific to .xml files.
> Netbeans opens, but I am not dropped into the .xml viewer with the file loaded.

Yes that is the same issue. If you attempt to open a PHP, Ruby, etc. file using finder, Netbeans will start but the file will not be loaded in the IDE. 

You can test this for yourself, create a php or some other file that should be handled by Netbeans and attempt to open it using finder. It should be the same behavior you reported in 88715.
Comment 12 dlipin 2010-09-15 17:58:35 UTC

*** This bug has been marked as a duplicate of bug 138943 ***
Comment 13 johnkramlich 2011-06-01 21:21:14 UTC
Here is a temporary work around involving AppleScript to enable drag and drop support to open files in NetBeans:

http://www.johnkramlich.com/blog/2011/06/01/launch-netbeans-when-opening-files-in-the-finder/

I'm posting here because it was one of the first links to show up on Google when I searched for a solution to this issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo