Bug 187316 - using search in branding wizard for bundle properties takes a long time/lots of cpu
using search in branding wizard for bundle properties takes a long time/lots ...
Status: RESOLVED WORKSFORME
Product: apisupport
Classification: Unclassified
Component: Templates
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Antonin Nebuzelsky
issues@apisupport
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 10:07 UTC by Kenneth Ganfield
Modified: 2010-06-25 15:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Ganfield 2010-06-08 10:07:04 UTC
Product Version = NetBeans IDE 6.9 RC2 (Build 201005312001)
Operating System = Mac OS X version 10.5.8 running on x86_64
Java; VM; Vendor = 1.6.0_17
Runtime = Java HotSpot(TM) 64-Bit Server VM 14.3-b01-101

1. create maven netbeans platform application
2. right-click branding module and select Branding. wait for build to finish.
3. click Resource Bundles tab in wizard.
4. enter term in Search text field (eg, about)

It takes too much time for the list of resource bundles to appear.
I had to force quit the IDE because it took over 10 minutes and was using 90% of cpu
Comment 1 Antonin Nebuzelsky 2010-06-25 15:15:28 UTC
I cannot reproduce the extreme slowness.

For me, it takes:

* several tens of seconds if the project is not built yet (and all modules from the default platform - the whole IDE -  are included in the list)

* just a few seconds if the project was already built (and thus the project is able to identify its platform correctly and the list includes only platform modules)

To your comment:
> "right-click branding module and select Branding. wait for build to finish."

The dialog box which notifies you about the need to have the project built first does not trigger the build. This is only warning. If you ignore it, the Branding editor uses your running IDE instance as the default platform for the project. After you build the project, the correct platform is identified and used.

Closing as worksforme now.

Ken, can you reproduce consistently? Can you show it to me on your machine?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo