Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187309 - When you format a php file, netbeans add a line feed before the closing tag, so the formatting is a total mess
When you format a php file, netbeans add a line feed before the closing tag, ...
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Formatting & Indentation
6.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: Petr Pisl
issues@php
69patch1-verified
:
: 187695 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-08 07:48 UTC by nomood
Modified: 2010-07-08 14:21 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Before format (3.09 KB, image/png)
2010-06-10 09:18 UTC, nomood
Details
After format (4.51 KB, image/png)
2010-06-10 09:19 UTC, nomood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nomood 2010-06-08 07:48:51 UTC
Product Version = NetBeans IDE 6.9 RC2 (Build 201005312001)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.6.0_16
Runtime = Java HotSpot(TM) Client VM 14.2-b01
Comment 1 Peter Pis 2010-06-09 07:06:57 UTC
Please evaluate.
Comment 2 Petr Pisl 2010-06-09 08:44:54 UTC
Do you mean in the html? The behavior is according the options. You can influence it. Could you provide an example?
Comment 3 nomood 2010-06-10 09:18:40 UTC
Created attachment 99968 [details]
Before format
Comment 4 nomood 2010-06-10 09:19:47 UTC
Created attachment 99969 [details]
After format

Hi there, thanks for the reply

I added two pictures before/after format in netbeans 6.9

Regards
Ludwig
Comment 5 Petr Pisl 2010-06-10 09:36:46 UTC
Now I understand:). Thanks. It's because the open tag <?= is not handled properly. I'm going to fix it. It's too late for NB 6.9, but it will be in the patch release for NB 6.9.
Comment 6 nomood 2010-06-10 09:50:40 UTC
Thanks ;)
Comment 7 Petr Pisl 2010-06-10 14:57:06 UTC
Fixed in the web-main clone. It should be available in tomorrow's dev build. Also I suggest it as 6.9.1 candidate.
Comment 8 Quality Engineering 2010-06-11 06:54:19 UTC
Integrated into 'main-golden', will be available in build *201006110001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/f503f0604307
User: Petr Pisl <ppisl@netbeans.org>
Log: #187309 -  When you format a php file, netbeans add a line feed before the closing tag, so the formatting is a total mess
Comment 9 Filip Zamboj 2010-06-12 01:31:14 UTC
verified. can be pushed to 6.9.1
Comment 10 rbalada 2010-06-16 10:12:42 UTC
Transplanted to release691 as 4056b62af811
Comment 11 Petr Pisl 2010-06-18 09:49:46 UTC
*** Bug 187695 has been marked as a duplicate of this bug. ***
Comment 12 Jaromir Uhrik 2010-07-08 14:21:17 UTC
Verified in the latest 6.9.1 build:
Product Version: NetBeans IDE 6.9.1 Dev (Build 201007062301)
Java: 1.6.0_20; Java HotSpot(TM) 64-Bit Server VM 16.3-b01-279
System: Mac OS X version 10.5.8 running on x86_64; MacRoman; en_US (nb)

on the following sample code:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
    <head>
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
        <title></title>
    </head>
    <body>
        <table>
            <tr class="tabClient<?=($i % 2)?>">
                <td><?=$myFile->nom?></td>
                <td><?=$myFile->ext?></td>
                <td><?=$myFile->size?></td>
            </tr>
            
        </table>
            
    </body>
</html>


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo