Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187183 - "Do you want to open project X?" message should have option to disable further messages
"Do you want to open project X?" message should have option to disable furthe...
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Generic Projects UI
6.x
PC Linux
: P3 (vote)
: 7.0
Assigned To: Jesse Glick
issues@projects
69patch1
: REGRESSION
Depends on:
Blocks: 175806
  Show dependency treegraph
 
Reported: 2010-06-04 06:53 UTC by rcasha
Modified: 2010-06-17 08:00 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rcasha 2010-06-04 06:53:58 UTC
Every time I click a link on a stack trace I get prompted with "Do you want to open project X?" if the project is not currently open. When going through a stack trace to identify a problem, this is very irritating. 

This message should have an checkbox to no longer show this message or something.
Comment 1 Jiri Rechtacek 2010-06-04 09:18:01 UTC
Please more information. Your steps? While debugging? Thanks
Comment 2 rcasha 2010-06-04 11:48:41 UTC
I have defined a number of NB projects for third-party libraries, such as Hibernate. These projects are normally kept closed.

Now, in v6.9rc2, any time I open a source file which exists in a project which is closed, NB prompts me to open the project. In fact I noticed that this dialog appears every time I switch to the open source file. 

For example, if I open the file HibernateEntityManager.java, I will get prompted to open the Hibernate project. If I press Ctrl-Tab twice, thus switching to another file and back, I get prompted again.

This did not occur in NB6.9 beta, but does happen in RC2.
Comment 3 Jesse Glick 2010-06-10 14:56:29 UTC
I think you have View > Synchronize Editor with Views checked. Uncheck it; you can then use C-S-1 to synchronize manually when you actually want to. Of course only C-S-1 (and C-S-2) should prompt you to open a project when the selected file is from a nonopen project; this should not happen when Synchronize... mode is on. Possibly caused by fix of bug #175806 though for now I cannot see how.
Comment 4 Jesse Glick 2010-06-10 14:57:26 UTC
core-main #49b89de1a7f2
Comment 5 Quality Engineering 2010-06-11 06:53:26 UTC
Integrated into 'main-golden', will be available in build *201006110001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/49b89de1a7f2
User: Jesse Glick <jglick@netbeans.org>
Log: #187183: "Do you want to open project X?" message should have option to disable further messages
Comment 6 rbalada 2010-06-16 08:55:37 UTC
Please verify bugfix for this bug, so it can be included in release691 repository.

Thanks,
-R
Comment 7 rcasha 2010-06-16 12:39:48 UTC
Verified against 201006130001 build. Thanks.
Comment 8 rbalada 2010-06-16 13:19:03 UTC
Transplanted to release691 as 09703852615c
Comment 9 Jesse Glick 2010-06-16 13:32:31 UTC
(In reply to comment #8)
> Transplanted to release691 as 09703852615c

Please omit the word 'as' in such messages, for the benefit of

http://wiki.netbeans.org/BrowserTools#Link_to_Mercurial_Changesets

Also this changeset does not yet seem to exist (not yet pushed?):

http://hg.netbeans.org/release691/rev/09703852615c
Comment 10 rbalada 2010-06-17 08:00:16 UTC
My modified version of the GM script works just fine, however my modifications were done in order to support my needs for sustaining purposes.

You're right, I forgot to push. It's been pushed now.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo