Bug 187131 - Deadlock while copy&pasting components
Deadlock while copy&pasting components
Status: RESOLVED FIXED
Product: guibuilder
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: 7.0
Assigned To: issues@guibuilder
issues@guibuilder
: THREAD
: 187295 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 12:00 UTC by Tomas Mysik
Modified: 2010-08-02 13:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (25.74 KB, text/plain)
2010-06-03 12:00 UTC, Tomas Mysik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2010-06-03 12:00:42 UTC
Created attachment 99782 [details]
thread dump

Steps:
- open 2 forms
- try to copy some components from one form to the other
=> deadlock

Product Version: NetBeans IDE Dev (Build 100602-82847c70b11c)
Java: 1.6.0_20; Java HotSpot(TM) 64-Bit Server VM 16.3-b01
System: Linux version 2.6.32-22-generic running on amd64; UTF-8; cs_CZ (nb)
Comment 1 Jan Stola 2010-06-04 07:22:22 UTC
This issue is another consequence of J.Tulach's incompatible change in
PropertySheet's threading model, see issue 168744. getPropertySets() used to be
called (by PropertySheet) in event-dispatch thread only. Now it is called also in other threads.

Accessible.getAccessibleContext() is called during creation of properties/property sets to determine whether the component should have accessibility properties. Unfortunately, JTextField.getAccessibleContext() accesses UI resources (it attempts to grab java.awt.Component$AWTTreeLock). Hence, it shouldn't be called outside AWT thread.
Comment 2 Jan Stola 2010-06-04 07:23:55 UTC
Yesterday, I saw this deadlock, too (on Windows) => changing Platform to All/All.
Comment 3 Tomas Mysik 2010-06-04 07:28:53 UTC
Isn't it a good candidate for NB 6.9.1?
Comment 4 Jan Stola 2010-06-07 12:47:09 UTC
Fixed.

Modified file: http://hg.netbeans.org/cdev/rev/c0e08a2fe58d

> Isn't it a good candidate for NB 6.9.1?

There is a whole series of problems caused by J.Tulach's fix of issue 168744. See, for example, issues 186528, 186191, 186746, 186375. We have to make sure that this area settles down before we port it to NB 6.9.1.
Comment 5 Tomas Pavek 2010-06-08 08:29:30 UTC
*** Bug 187295 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo