Bug 187116 - Code indention in if/else behaves incorrectly
Code indention in if/else behaves incorrectly
Status: RESOLVED DUPLICATE of bug 188112
Product: java
Classification: Unclassified
Component: Editor
6.x
PC All
: P3 with 2 votes (vote)
: TBD
Assigned To: Dusan Balek
issues@java
:
: 188342 189927 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 07:02 UTC by aschild
Modified: 2010-10-21 12:37 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description aschild 2010-06-03 07:02:09 UTC
Code idention in java code behaves incorrect.

Having the given code:

public void method1()
{
    if (true)
    {
            
    }
}

now go to the endif tag and type "else" and enter.
The result is now as below, the else is not indented at all.

       if (true)
        {
            
        }
 else
     
    }
Comment 1 eugene-71 2010-06-16 15:58:34 UTC
Have same problem.
Comment 2 Peter Pis 2010-07-15 08:00:13 UTC
*** Bug 188342 has been marked as a duplicate of this bug. ***
Comment 3 Peter Pis 2010-08-27 08:36:37 UTC
*** Bug 189927 has been marked as a duplicate of this bug. ***
Comment 4 mobow 2010-09-24 09:50:26 UTC
Same here.
Comment 5 Dusan Balek 2010-10-21 12:37:09 UTC
Already fixed.

*** This bug has been marked as a duplicate of bug 188112 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo