Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187107 - Debugger temporary windows do not close
Debugger temporary windows do not close
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Actions/Menu/Toolbar
6.x
PC Windows Vista
: P2 (vote)
: 7.0
Assigned To: issues@editor
issues@editor
69patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 21:25 UTC by mclaassen
Modified: 2010-07-08 07:34 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mclaassen 2010-06-02 21:25:47 UTC
I didn't see anything like this in the reported bugs, but perhaps I didn't search for the right thing.

I like the debugger watch windows that pop up in the editor...especially the ones for complex objects.  However, they often don't go away and right now I have one that is sticking around even after the debugger session is ended.

Changing tabs, maximizing tabs, ... nothing will get it to leave except restarting netbeans.

This is a show stopper bug as far as I am concerned.

It seems to happen when I advance the debugger when the temporary watch window is up.  Once this happens, basically nothing will bring it down.
Comment 1 Martin Entlicher 2010-06-03 12:16:36 UTC
Clicking into the Editor area in the tab where the extended tooltip was originally opened closes that tooltip. Clicking into a different editor tab does not close it.
Comment 2 mclaassen 2010-06-03 13:46:21 UTC
I confirmed that clicking the editor in the correct location closes the window.

I would, however, contend that this is insufficient.  It is common for the debugger to enter other files when stepping through things.  Once the editor switches context the window is essentially locked in place.

I believe others will experience this problem as well and, like me, have to resort to restarting netbeans to get rid of it (until they are told how to).

When I wanted to close it, the first think I tried was clicking in the editor and then I tried to use ESCAPE.  These seemed like the most natural things to try and so I would recommend these as possible solutions.

I am not sure why it was designed to stay up unless the editor was clicked at a certain location, but I am guessing this was on purpose.  If those reasons are still valid, then maybe this part of the design should stay.  However, I think ESCAPE should close the window always.
Comment 3 Vitezslav Stejskal 2010-06-04 09:10:27 UTC
I'm looking into this.
Comment 4 Vitezslav Stejskal 2010-06-04 10:14:30 UTC
http://hg.netbeans.org/jet-main/rev/a3d142ad8e3e

I'm leaving this as P2 (no showstopper for 6.9) and nominating it as a 6.9.1_CANDIDATE. Also CCing QE to make sure that this is ok to leave for 6.9.1.
Comment 5 mclaassen 2010-06-04 12:43:17 UTC
I am sure there are lots of pressures on the people deciding the release schedule, but I think this is big deal and waiting for a patch release is not appropriate.

Two out of the first 3 times I used the feature I had to restart my IDE to continue my work.  The stalwarts are going to just be annoyed, but a new user evaluating the NB debugger would probably quit right there.
Comment 6 Vitezslav Stejskal 2010-06-04 15:24:00 UTC
(In reply to comment #5)
> Two out of the first 3 times I used the feature I had to restart my IDE to
> continue my work.

Does closing all editors help? It should I would say.
Comment 7 mclaassen 2010-06-04 19:19:28 UTC
Closing the tab that originally launched the window closes it.  Now that I know what caused the problem I know how to resolve it.  Others will not know this trick, although they may guess better that I.

The first day I used 6.9, this happened to me twice.  The quickest solution I could think of at the time (with the highest likelihood of success) was to just restart.  Later, I reproduced again and then reported it.

So, the questions are:
* How likely is this going to be hit
* When it does, how frustrating will it be (can a simple workaround be guessed)
* What will fixing this due to the other factors that the team is considering.

Tough choices, I know...
Comment 8 Quality Engineering 2010-06-05 07:47:59 UTC
Integrated into 'main-golden', will be available in build *201006050001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a3d142ad8e3e
User: Vita Stejskal <vstejskal@netbeans.org>
Log: #187107: close a tooltip when its editor is closed
Comment 9 Peter Pis 2010-06-07 13:09:00 UTC
V. NetBeans IDE 6.9 (Build 201006041701)
Comment 10 rbalada 2010-06-16 10:01:37 UTC
Transplanted to release691 as 9a0fa9ad5e28
Comment 11 Martin Fousek 2010-07-08 07:34:56 UTC
Verified in NetBeans IDE 6.9.1 Dev (Build 201007062301).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo