Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 187050 - Scrolling in Diff window should try to keep lines matched
Scrolling in Diff window should try to keep lines matched
Status: VERIFIED FIXED
Product: utilities
Classification: Unclassified
Component: Diff
6.x
All All
: P2 (vote)
: 7.0
Assigned To: Tomas Stupka
diff-issues@utilities
69patch1
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-01 18:14 UTC by swpalmer
Modified: 2010-06-18 08:14 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description swpalmer 2010-06-01 18:14:33 UTC
Product Version = NetBeans IDE 6.9 RC1 (Build 201005242201)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.6.0_20
Runtime = Java HotSpot(TM) Client VM 16.3-b01

I removed a bunch of lines from a Java file.  When I scroll the diff view the lines after my edit are scrolled the wrong way, or the wrong side is scrolled, such that they are kept farther apart than then need to be.  The scrolling should try to keep things lined up as much as possible.
Comment 1 Ondrej Vrabec 2010-06-02 08:58:32 UTC
hmm, a regression caused by http://hg.netbeans.org/cdev/rev/60a160f1bf13
Comment 2 Ondrej Vrabec 2010-06-02 09:04:45 UTC
fix: http://hg.netbeans.org/cdev/rev/5f46339f7900
Comment 3 Quality Engineering 2010-06-03 06:08:48 UTC
Integrated into 'main-golden', will be available in build *201006030001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/5f46339f7900
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #187050 - Scrolling in Diff window should try to keep lines matched
Comment 4 rbalada 2010-06-16 08:54:41 UTC
Please verify bugfix for this bug, so it can be included in release691 repository.

Thanks,
-R
Comment 5 Petr Blaha 2010-06-17 11:51:45 UTC
verified
Comment 6 rbalada 2010-06-18 08:14:06 UTC
main #5f46339f7900 transplanted to release691 #b2a0c70a3202


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo