Bug 186913 - IndexOutOfBoundsException: Index: 3, Size: 3
IndexOutOfBoundsException: Index: 3, Size: 3
Status: RESOLVED DUPLICATE of bug 180960
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@platform
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 18:07 UTC by xonev
Modified: 2010-06-02 07:54 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.25 KB, text/plain)
2010-05-28 18:07 UTC, xonev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xonev 2010-05-28 18:07:51 UTC
Build: NetBeans IDE 6.9 Beta (Build 201004200117)
VM: OpenJDK Client VM, 14.0-b16, OpenJDK Runtime Environment, 1.6.0_18-b18
OS: Linux

User Comments:
xonev: I was using the editor and control-clicked on a static PHP method in order to go to the place where it was declared.  When I did this, the error popped up, and the editor did not go to the place of the method's declaration as expected.

GUEST: Right clicked on tab of open document and selected 'close all documents'

GUEST: I was closing all open documents

GUEST: opening smarty template with .html extension

GUEST: i just opened a js file in my project

christiaensm: I was closing all tabs in a window (right click on a tab and close everything).

GUEST: trying to open .html file (which is smarty template in fact)




Stacktrace: 
java.lang.IndexOutOfBoundsException: Index: 3, Size: 3
   at java.util.ArrayList.RangeCheck(ArrayList.java:571)
   at java.util.ArrayList.get(ArrayList.java:349)
   at org.netbeans.swing.tabcontrol.DefaultTabDataModel.fireIndicesChanged(DefaultTabDataModel.java:490)
   at org.netbeans.swing.tabcontrol.DefaultTabDataModel.setTabs(DefaultTabDataModel.java:120)
   at org.netbeans.core.windows.view.ui.tabcontrol.TabbedAdapter.setTopComponents(TabbedAdapter.java:234)
   at org.netbeans.core.windows.view.ui.TabbedHandler.setTopComponents(TabbedHandler.java:154)
Comment 1 xonev 2010-05-28 18:07:54 UTC
Created attachment 99634 [details]
stacktrace
Comment 2 Stanislav Aubrecht 2010-06-02 07:54:49 UTC

*** This bug has been marked as a duplicate of bug 180960 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo