Bug 186879 - NullPointerException at org.netbeans.modules.erd.io.DocumentLoad.getChildNode
NullPointerException at org.netbeans.modules.erd.io.DocumentLoad.getChildNode
Status: RESOLVED WONTFIX
Product: contrib
Classification: Unclassified
Component: Code
7.2
Other Windows 7 x64
: P1 (vote)
: TBD
Assigned To: issues@contrib
issues@contrib
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 10:07 UTC by Exceptions Reporter
Modified: 2013-12-26 18:26 UTC (History)
32 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.81 KB, text/plain)
2010-05-28 10:07 UTC, Exceptions Reporter
Details
stacktrace (4.81 KB, text/plain)
2010-05-29 01:53 UTC, javydreamercsw
Details
stacktrace (4.81 KB, text/plain)
2010-06-04 11:54 UTC, javydreamercsw
Details
stacktrace (4.81 KB, text/plain)
2010-06-25 15:31 UTC, esmithbss
Details
stacktrace (437 bytes, text/plain)
2010-12-17 09:38 UTC, Tomas Mysik
Details
stacktrace (4.81 KB, text/plain)
2011-06-18 19:53 UTC, Maksim Khramov
Details
stacktrace (4.81 KB, text/plain)
2011-07-16 16:06 UTC, Maksim Khramov
Details
stacktrace (5.57 KB, text/plain)
2011-09-10 08:29 UTC, paolosca
Details
stacktrace (437 bytes, text/plain)
2011-10-20 15:05 UTC, alied
Details
stacktrace (437 bytes, text/plain)
2012-09-22 21:53 UTC, alied
Details
stacktrace (5.54 KB, text/plain)
2012-10-05 19:02 UTC, javydreamercsw
Details
stacktrace (5.54 KB, text/plain)
2012-10-30 00:30 UTC, alied
Details
stacktrace (5.54 KB, text/plain)
2013-05-24 13:09 UTC, viggonavarsete
Details
stacktrace (5.54 KB, text/plain)
2013-05-24 13:12 UTC, viggonavarsete
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2010-05-28 10:07:41 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-5211-on-100521)
VM: Java HotSpot(TM) Client VM, 16.0-b13, Java(TM) SE Runtime Environment, 1.6.0_18-b07
OS: Windows XP

User Comments:
michaelnazarov: Steps to reproduce:

1. Call context menu on connected JavaDB connection.
2. Select "Show ER-Diagram" menu item.

rad1x: Opening ER-Diagram from services panel for localhost mysql DB

GUEST: tried to create an ER diagram from a mysql database




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.erd.io.DocumentLoad.getChildNode(DocumentLoad.java:179)
   at org.netbeans.modules.erd.io.DocumentLoad.load(DocumentLoad.java:84)
   at org.netbeans.modules.erd.model.DocumentSerializer$1.run(DocumentSerializer.java:78)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1418)
   at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1957)
Comment 1 Exceptions Reporter 2010-05-28 10:07:44 UTC
Created attachment 99593 [details]
stacktrace
Comment 2 javydreamercsw 2010-05-29 01:53:41 UTC
Created attachment 99639 [details]
stacktrace

Trying to create UML Diagram
Comment 3 Peter Pis 2010-05-31 08:41:32 UTC
Please evaluate.
Comment 4 javydreamercsw 2010-06-04 11:54:19 UTC
Created attachment 99816 [details]
stacktrace

Show E-R Diagram
Comment 5 Exceptions Reporter 2010-06-08 18:42:36 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=168022
Comment 6 esmithbss 2010-06-25 15:31:47 UTC
Created attachment 100420 [details]
stacktrace

Attempting to show E-R Diagram for an Oracle Database.
Comment 7 Tomas Mysik 2010-12-17 09:38:18 UTC
Created attachment 104199 [details]
stacktrace

show er diagram from postgresql database
Comment 8 Maksim Khramov 2011-06-18 19:53:16 UTC
Created attachment 108976 [details]
stacktrace
Comment 9 Maksim Khramov 2011-07-16 16:06:52 UTC
Created attachment 109467 [details]
stacktrace
Comment 10 paolosca 2011-09-10 08:29:51 UTC
Created attachment 110595 [details]
stacktrace

Right clicked on a postgres database (from the services panel) and selected Show-ER Diagram
Comment 11 alied 2011-10-20 15:05:55 UTC
Created attachment 112270 [details]
stacktrace

-Go to Services/Databases.
-Select "jdbc:mysql://localhost:port/schema"
-right click and select "Show E-R diagram"
Comment 12 Marian Mirilovic 2011-11-23 11:14:11 UTC
101 dups
Comment 13 Sergey Petrov 2011-11-23 11:17:18 UTC
looks like it's not properly assigned, as org.netbeans.modules.erd doesn't look related to uml
Comment 14 javydreamercsw 2012-03-14 12:50:19 UTC
Changing to IDE for evaluation of the correct component to assign.
Comment 15 452 2012-06-11 19:18:14 UTC
-Go to Sources/name.dbschema.
-right click and select "Show E-R diagram"
Comment 16 alied 2012-09-22 21:53:10 UTC
Created attachment 124757 [details]
stacktrace

after creating a new ERD diagram
Comment 17 javydreamercsw 2012-10-05 19:02:13 UTC
Created attachment 125484 [details]
stacktrace

getting ER diagram
Comment 18 alied 2012-10-30 00:30:11 UTC
Created attachment 126758 [details]
stacktrace

-Selected a DB Connection from the Services view
-right-click
-select Show ER-Diagram
Comment 19 Exceptions Reporter 2013-01-24 17:49:50 UTC
This bug already has 150 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=168022
Comment 20 Exceptions Reporter 2013-01-24 17:52:44 UTC
This bug already has 150 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=168022
Comment 21 viggonavarsete 2013-05-24 13:09:54 UTC
Created attachment 134868 [details]
stacktrace

Tried to generate an ER-diagram from a DB2-database
Comment 22 viggonavarsete 2013-05-24 13:12:55 UTC
Created attachment 134869 [details]
stacktrace

Tried to generate an ER-diagram from the derby sample database bundled with Netbeans, same issue as when I tried against a DB2-database, maybe showing that the issue isn't DB-dependent..
Comment 23 aosamai 2013-05-24 13:18:10 UTC
hi guys, where is that context menu to generate ER diagram?
Comment 24 Marian Mirilovic 2013-06-16 20:31:26 UTC
Report against http://code.google.com/p/erd-netbeans-module/
Comment 25 ionuion 2013-12-26 18:26:52 UTC
Reported Issue 1 on the project Issue tracker:
https://code.google.com/p/erd-netbeans-module/issues/detail?id=1

The current bug mentioned in the bug description


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo