Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 186858 - Incorrect CC in Views
Incorrect CC in Views
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Zend
6.x
PC Linux
: P2 with 1 vote (vote)
: 7.0
Assigned To: rmatous
issues@php
69patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 05:04 UTC by Tomas Mysik
Modified: 2010-07-27 15:17 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2010-05-28 05:04:44 UTC
Controller:
$this->view->something

View:
$this->something

NetBeans currently offers just $something which is incorrect.

Filipe, please confirm. Radku, we need to improve editor part to support this scenario.

This is definitely a candidate for NB 6.9.1.
Comment 1 Tomas Mysik 2010-05-31 10:42:01 UTC
Project's part fixed, reassigning to the editor. Thanks.
http://hg.netbeans.org/web-main/rev/3dc91d8afaf8
Comment 2 Filip Zamboj 2010-05-31 12:37:45 UTC
(In reply to comment #0)
> Controller:
> $this->view->something
> 
> View:
> $this->something
> 
> NetBeans currently offers just $something which is incorrect.
> 
> Filipe, please confirm. Radku, we need to improve editor part to support this
> scenario.
> 
> This is definitely a candidate for NB 6.9.1.

you guys probably already strated working on this .. however, confirmed. the problem occurred because of difference between symfony and zend call in view. You use $something in symfony but $this->something in zend. 

I agree, that this is 6.9.1 candidate
Comment 3 rmatous 2010-06-02 13:20:41 UTC
This is proposed patch for 6.9.1: 
http://hg.netbeans.org/web-main/rev/1b115734c4c2

- in CC for views offered $this
- after this completes fields (taken from $this->view->*) as $this->*
- CC after $this->*->| doesn't complete
- no goto declaration and so on 

Relatively safe, might be transplanted, but incomplete (see above)

Better impl. deserves more changes and might cause poor quality. I will start to work on it, but not sure if it will be safe enough to put it into 6.9.1
Comment 4 Quality Engineering 2010-06-03 06:09:29 UTC
Integrated into 'main-golden', will be available in build *201006030001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/3dc91d8afaf8
User: Tomas Mysik <tmysik@netbeans.org>
Log: Project's part of #186858: Incorrect CC in Views

Editor's part is to be done now.
Comment 5 Tomas Mysik 2010-06-18 08:48:44 UTC
Filipe, please verify. Thanks.
Comment 6 Tomas Mysik 2010-06-18 09:26:44 UTC
Reopening beause we must first agreed whether it is fixed or not (the editor's part).
Comment 7 rbalada 2010-06-22 08:00:21 UTC
Added the 69patch1 status whiteboard keyword. I've already ported changesets into releasee691 repository and the status whiteboard keyword helps me keep this bug on "PORTED UNVERIFIED" list, please do not remove 69patch1 status whiteboard keyword without backing out the changesets first.

Related changesets are:
release691 #4f436738ee7a (Tomas' project's part)
release691 #b8924fc2892d (Radek's part [editor?])
Comment 8 rbalada 2010-06-23 15:40:07 UTC
In case we would have agreed on rollback from release691 repository, there exist also one more related changeset in release691 #7d2f9a18e0b6 which is a fix for specification version and module dependency issue #187769 "BUILD FAILED".

The rollback TASK is covered by issue 187962. If we would have agreed on not rolling back from release691 repository, then please remove 6.9.1_CANDIDATE keyword from issue 187962 and mark it INVALID.

Thanks,
-R
Comment 9 rmatous 2010-06-23 15:48:42 UTC
Keep in 6.9.1, no rollback! Filip is going to test for regressions again(though already tested by myself and users), close this issue as fixed(and create new one for net release) 

This fix is real improvement(although not ideal and 100%), any better fix can't be delivered in guaranteed quality for 6.9.1 and should come into next release.
Comment 10 Filip Zamboj 2010-06-24 14:42:26 UTC
(In reply to comment #9)
> Keep in 6.9.1, no rollback! Filip is going to test for regressions again(though
> already tested by myself and users), close this issue as fixed(and create new
> one for net release) 
> 
> This fix is real improvement(although not ideal and 100%), any better fix can't
> be delivered in guaranteed quality for 6.9.1 and should come into next release.

verified in 
Product Version: NetBeans IDE Dev (Build 100624-37b8a71917c5)
Java: 1.6.0_16; Java HotSpot(TM) 64-Bit Server VM 14.2-b01

two additional bugs were filed related to this functionality 
BUG 188055
BUG 188056

even though two additional bugs have been filed this one can be transplanted into 6.9.1
Comment 11 Filip Zamboj 2010-06-24 14:43:24 UTC
(In reply to comment #9)
> even though two additional bugs have been filed this one can be transplanted
> into 6.9.1

well, not transplanted but kept as it is I meant
Comment 12 rbalada 2010-06-27 19:49:54 UTC
Re-seting the 6.9.1_CANDIDATE keyword. Updated the status whiteboard.
Comment 13 Jaromir Uhrik 2010-07-27 15:17:54 UTC
Since Filip has verified in trunk I checked that fixes are in 6.9.1 clone and I am marking as verified in 6.9.1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo