Bug 186843 - Project Group doesn't work on new installation
Project Group doesn't work on new installation
Status: RESOLVED WORKSFORME
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
6.x
PC Windows Vista
: P4 (vote)
: TBD
Assigned To: Jesse Glick
issues@projects
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 20:15 UTC by ekenschaft
Modified: 2010-05-28 15:57 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ekenschaft 2010-05-27 20:15:56 UTC
Product Version = NetBeans IDE 6.9 RC1 (Build 201005242201)
Operating System = Windows Vista version 6.0 running on x86
Java; VM; Vendor = 1.6.0_20
Runtime = Java HotSpot(TM) Client VM 16.3-b01

I just made the transition from 6.9 Beta to 6.9 RC1. The first thing I did was create a Project Group based on an existing directory structure. It came up empty, no projects. Once I loaded the projects manually, closed and reopened the group, then the projects were there.
Comment 1 Jesse Glick 2010-05-28 14:26:18 UTC
No clue what would be going on there; need steps to reproduce from scratch.
Comment 2 ekenschaft 2010-05-28 15:47:50 UTC
I've been learning NetBeans using 6.9 Beta. I typically use Project Groups defined by directory structure, where the top folder is the main project, and subprojects are in subfolders.

Yesterday, I installed netbeans-6.9rc1-ml-javase-windows.exe. The first thing I did after installation was create a new Project Group, based on a directory structure of existing projects. However, it did not detect the projects, but just brought up an empty Project Group.

If I remember right, I then installed Java EE plug-ins, thinking the missing plug-ins might have prevented the projects from loading. It did not immediately load any of the missing projects, not surprisingly.

I then used "Open Project" to open the individual projects; selected Project Group / (none); and reopened the Project Group I had previously created. This time it found the projects, and has been working fine since.

If you can't repeat this easily, feel free to mark it unrepeatable and move on. I'm willing to accept that it's a fluke.
Comment 3 Jesse Glick 2010-05-28 15:57:13 UTC
Can't reproduce. Start a dev build incl. ergonomics ("feature on demand") with a fresh user dir. Create new project group by folder on the top dir of a previously created FeedReader sample. Java SE feature was enabled and the module suite project and its component module projects were opened.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo