Bug 186701 - Unable to save a file
Unable to save a file
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 03:19 UTC by xonev
Modified: 2010-06-11 16:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Log of the IDE shortly after the error occurred. (39.44 KB, text/plain)
2010-05-31 19:06 UTC, xonev
Details
patched module (945.52 KB, application/octet-stream)
2010-06-01 10:53 UTC, Stanislav Aubrecht
Details
Messages log. (33.36 KB, text/plain)
2010-06-10 21:31 UTC, xonev
Details
UI Gestures Log. (339.22 KB, text/plain)
2010-06-10 21:32 UTC, xonev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xonev 2010-05-26 03:19:29 UTC
Product Version = NetBeans IDE 6.9 Beta (Build 201004200117)
Operating System = Linux version 2.6.32-22-generic running on i386
Java; VM; Vendor = 1.6.0_18
Runtime = OpenJDK Client VM 14.0-b16

I was editing one of my PHP files as usual, but when I pressed ctrl-S, it would not save.  I attempted to access "Save" through the "File" menu, but it was "grayed out".  After switching to other files and trying a couple of different things to no avail, I attempted to close the editor.  It gave me a notification that my file had not been saved and an option to save it.  I clicked "Save" and the IDE shut down, but when I brought it back up, my changes had not been saved.  Unfortunately, I have not been able to reproduce the error, but if it happens again I will add to this ticket.
Comment 1 Peter Pis 2010-05-26 08:14:38 UTC
To reported: Could you please attach messages.log of that NB session while save action was not working.

Reassigning to php.
Comment 2 Tomas Mysik 2010-05-26 08:53:42 UTC
Unlikely related to PHP support itself... Please, reopen this issue and attach the IDE log as we asked before so we can investigate it.

Thanks a lot.
Comment 3 xonev 2010-05-31 19:06:57 UTC
Created attachment 99686 [details]
Log of the IDE shortly after the error occurred.
Comment 4 xonev 2010-05-31 19:08:07 UTC
OK, sorry I didn't attach the IDE log before, but during my process of figuring
out what was going on, I had restarted the IDE (and I figured that the log
wouldn't have been present still, but I didn't actually check to make sure).

Anyway, the problem happened again.  This time, I hit ctrl-Tab to change the
file I was editing and an Exception window popped up.  I decided I didn't have
time to look at it at that moment, so I closed the Exception window by clicking
on "Cancel" (usually things continue to work as usual when this happens). 
After clicking on "Cancel", I edited the file I was intending to work on and
hit ctrl-S, but nothing happened.  I was still able to edit and save other
files, but not that particular file.

I have attached the IDE log this time.
Comment 5 xonev 2010-05-31 19:15:12 UTC
This time, when I closed the file itself, and clicked "Save" when it asked me if I wanted to save it as it was closing, it seemed to save correctly.
Comment 6 Tomas Mysik 2010-05-31 21:20:54 UTC
(In reply to comment #4)
> I figured that the log wouldn't have been present still

Three logs are kept, have a look at <nbuserdir>/var/log/ directory.
Comment 7 Tomas Mysik 2010-05-31 21:22:24 UTC
Looking into the LOG file, exception occured in NB window system - please evaluate, thanks.
Comment 8 Antonin Nebuzelsky 2010-06-01 09:00:28 UTC
A duplicate of issue 180960?

Seems like that issue is more severe than we thought. If it prevents saving a file, we should consider fixing it in 6.9 rather than in 6.9.1 as we originally planned.
Comment 9 Stanislav Aubrecht 2010-06-01 10:53:32 UTC
Created attachment 99702 [details]
patched module

reporter, please copy the patched module to your netbeans 6.9 RC folder (<netbeans dir>/platform/modules) and let us know if it fixes the problem.
if you can verify that you can no longer reproduce this issue with the patched jar within the next day or two we'll backport the fix to 6.9 release. 
thanks
Comment 10 Stanislav Aubrecht 2010-06-03 13:09:10 UTC

*** This bug has been marked as a duplicate of bug 180960 ***
Comment 11 xonev 2010-06-03 16:14:15 UTC
I have copied the module and will be testing it over the next number of days.  I'll notify if the problem happens again.
Comment 12 xonev 2010-06-10 21:27:08 UTC
I have been using Netbeans 6.9 with the patched module, but today I ran into the problem once again.
Comment 13 xonev 2010-06-10 21:31:08 UTC
Created attachment 99995 [details]
Messages log.
Comment 14 xonev 2010-06-10 21:32:00 UTC
Created attachment 99996 [details]
UI Gestures Log.

I've attached the messages log and uigestures log.
Comment 15 Stanislav Aubrecht 2010-06-11 06:40:07 UTC
the stack trace from the new log file is from unpatched version of the tab control module.
you either didn't copy the patched module or you copied to wrong location
Comment 16 xonev 2010-06-11 16:05:33 UTC
I don't see how it could have been the unpatched module unless the unpatched module was the one attached.

I double-checked the bash script that I've been running to start Netbeans to make sure it was starting the version I thought it was from the directory I thought it was starting from.  Then I re-downloaded the "patched module" and ran diff on it and the module which I have installed currently in that Netbeans installation.  They are identical.

So, I see three possibilities here:  Netbeans is using modules from a different directory than the one the binary file which executes Netbeans is in, the stack trace was from the patched module, or the "patched module" isn't actually patched at all (you gave me the wrong one).
Comment 17 Stanislav Aubrecht 2010-06-11 16:43:14 UTC
you might need to clear the user dir first, i think that netbeans module system builds a cache of all jars there


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo