Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 186683 - java.util.ConcurrentModificationException at java.util.HashMap$HashIterator.nextEntry
java.util.ConcurrentModificationException at java.util.HashMap$HashIterator.n...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Alexander Simon
issues@cnd
EXCEPTIONS_REPORT, 69patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-25 16:11 UTC by Alexander Simon
Modified: 2010-07-09 14:30 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.60 KB, text/plain)
2010-05-25 16:11 UTC, Alexander Simon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2010-05-25 16:11:22 UTC
Build: NetBeans IDE Dev (Build 100525-9004d7bb1730)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: SunOS

Stacktrace: 
java.util.ConcurrentModificationException
   at java.util.HashMap$HashIterator.nextEntry(HashMap.java:793)
   at java.util.HashMap$KeyIterator.next(HashMap.java:828)
   at org.netbeans.modules.cnd.modelimpl.impl.services.TypeHierarchyResolverImpl.getSubTypes2(TypeHierarchyResolverImpl.java:140)
   at org.netbeans.modules.cnd.modelimpl.impl.services.TypeHierarchyResolverImpl.getSubTypes2(TypeHierarchyResolverImpl.java:124)
   at org.netbeans.modules.cnd.modelimpl.impl.services.TypeHierarchyResolverImpl.getSubTypes(TypeHierarchyResolverImpl.java:91)
   at org.netbeans.modules.cnd.api.model.services.CsmVirtualInfoQuery$Empty.getOverriddenMethods(CsmVirtualInfoQuery.java:241)
Comment 1 Alexander Simon 2010-05-25 16:11:26 UTC
Created attachment 99448 [details]
stacktrace
Comment 2 Alexander Simon 2010-05-25 16:46:31 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/0cb857c0840c
Comment 3 Quality Engineering 2010-05-26 07:19:19 UTC
Integrated into 'main-golden', will be available in build *201005260001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0cb857c0840c
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed BZ#186683 java.util.ConcurrentModificationException at java.util.HashMap$HashIterator.nextEntry
Comment 4 Vladimir Voskresensky 2010-05-26 09:55:34 UTC
-- use concurrent map, because it has concurrent read/write access by clients
http://hg.netbeans.org/cnd-main?cmd=changeset;node=324d9d6b1972
Comment 5 Quality Engineering 2010-05-27 07:47:09 UTC
Integrated into 'main-golden', will be available in build *201005270001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/324d9d6b1972
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: add fix for #186683: java.util.ConcurrentModificationException at java.util.HashMap$HashIterator.nextEntry
-- use concurrent map, because it has concurrent read/write access by clients
Comment 6 rbalada 2010-06-16 08:54:25 UTC
Please verify bugfix for this bug, so it can be included in release691 repository.

Thanks,
-R
Comment 7 Alexander Simon 2010-06-17 13:33:26 UTC
fixed in release691:
0cb857c0840c transplanted to cfdd11e7c61e
324d9d6b1972 manually converted to c45e53e251d9
Comment 8 rbalada 2010-06-17 14:16:16 UTC
Please mark bugs VERIFIED-FIXED before transplanting to release691.

Please verify this bugfix asap.

Thanks,
-R
Comment 9 Alexander Pepin 2010-06-18 14:21:25 UTC
please provide test scenario
Comment 10 Alexander Simon 2010-06-21 07:41:50 UTC
Exception is random.
To reproduce bug you should take a project with large class inheritance tree.
For example ACE+TAO.
Open file with base (ACE_wrappers/TAO/tao/Object.h for ACE+TAO) class. While overridden method are computed try select some identifiers in file or/and try hyperlink on some virtual methods.
Some times you will have an exception.
Comment 11 Alexander Pepin 2010-06-21 10:05:56 UTC
mark as verified despite it's very difficult to verify
Comment 12 Alexander Pepin 2010-07-09 14:30:46 UTC
verified in 6.9.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo