Bug 186669 - AssertionError at org.netbeans.core.io.ui.IOWindow$IOWindowImpl.removeTab
AssertionError at org.netbeans.core.io.ui.IOWindow$IOWindowImpl.removeTab
Status: RESOLVED DUPLICATE of bug 180960
Product: platform
Classification: Unclassified
Component: Output Window
6.x
All All
: P3 (vote)
: 7.0
Assigned To: Martin Entlicher
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-25 13:56 UTC by mpapamichael
Modified: 2011-01-14 16:13 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.31 KB, text/plain)
2010-05-25 13:56 UTC, mpapamichael
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mpapamichael 2010-05-25 13:56:09 UTC
Build: NetBeans IDE Dev (Build 201005192201)
VM: Java HotSpot(TM) Client VM, 16.0-b13, Java(TM) SE Runtime Environment, 1.6.0_18-b07
OS: Windows XP

Stacktrace: 
java.lang.AssertionError
   at org.netbeans.core.io.ui.IOWindow$IOWindowImpl.removeTab(IOWindow.java:342)
   at org.netbeans.core.io.ui.IOWindow.remove(IOWindow.java:116)
   at org.openide.windows.IOContainer.remove(IOContainer.java:162)
   at org.netbeans.core.output2.Controller.performCommand(Controller.java:425)
   at org.netbeans.core.output2.Controller.eventDispatched(Controller.java:101)
   at org.netbeans.core.output2.IOEvent.dispatch(IOEvent.java:281)
Comment 1 mpapamichael 2010-05-25 13:56:12 UTC
Created attachment 99438 [details]
stacktrace
Comment 2 Martin Entlicher 2011-01-14 15:36:01 UTC
The first exception is caused by JTatoo:
java.lang.ArrayIndexOutOfBoundsException: -1
	at com.jtattoo.plaf.BaseTabbedPaneUI$ScrollableTabSupport.setLeadingTabIndex(Unknown Source)
	at com.jtattoo.plaf.BaseTabbedPaneUI$ScrollableTabSupport.scrollTabToVisible(Unknown Source)
	at com.jtattoo.plaf.BaseTabbedPaneUI$TabSelectionHandler.stateChanged(Unknown Source)
	at javax.swing.JTabbedPane.fireStateChanged(JTabbedPane.java:400)
	at org.openide.awt.CloseButtonTabbedPane.fireStateChanged(CloseButtonTabbedPane.java:515)
	at javax.swing.JTabbedPane$ModelListener.stateChanged(JTabbedPane.java:253)
	at javax.swing.DefaultSingleSelectionModel.fireStateChanged(DefaultSingleSelectionModel.java:116)
	at javax.swing.DefaultSingleSelectionModel.setSelectedIndex(DefaultSingleSelectionModel.java:50)
	at javax.swing.JTabbedPane.setSelectedIndexImpl(JTabbedPane.java:599)
	at javax.swing.JTabbedPane.removeTabAt(JTabbedPane.java:958)
	at javax.swing.JTabbedPane.remove(JTabbedPane.java:1005)
	at org.netbeans.core.io.ui.IOWindow$IOWindowImpl.removeTab(IOWindow.java:349)


The second is caused by 
java.lang.IndexOutOfBoundsException: Index: 3, Size: 3
	at java.util.ArrayList.RangeCheck(ArrayList.java:547)
	at java.util.ArrayList.get(ArrayList.java:322)
	at org.netbeans.swing.tabcontrol.DefaultTabDataModel.fireContentsChanged(DefaultTabDataModel.java:457)
	at org.netbeans.swing.tabcontrol.DefaultTabDataModel.setText(DefaultTabDataModel.java:162)
	at org.netbeans.swing.tabcontrol.TabbedContainer.setTitleAt(TabbedContainer.java:704)
	at org.netbeans.core.windows.view.ui.TabbedHandler.topComponentNameChanged(TabbedHandler.java:239)
	at org.netbeans.core.windows.view.ui.AbstractModeContainer.updateName(AbstractModeContainer.java:191)
	at org.netbeans.core.windows.view.ModeView.updateName(ModeView.java:172)
	at org.netbeans.core.windows.view.DefaultView.changeGUI(DefaultView.java:362)
	at org.netbeans.core.windows.ViewRequestor.dispatchRequest(ViewRequestor.java:272)
	at org.netbeans.core.windows.ViewRequestor.processRequest(ViewRequestor.java:248)
	at org.netbeans.core.windows.ViewRequestor.postRequest(ViewRequestor.java:186)
	at org.netbeans.core.windows.ViewRequestor.scheduleRequest(ViewRequestor.java:126)
	at org.netbeans.core.windows.Central.topComponentDisplayNameChanged(Central.java:1562)
	at org.netbeans.core.windows.WindowManagerImpl.topComponentDisplayNameChanged(WindowManagerImpl.java:1169)
	at org.netbeans.core.windows.WindowManagerImpl.topComponentHtmlDisplayNameChanged(WindowManagerImpl.java:1175)
	at org.openide.windows.TopComponent.setHtmlDisplayName(TopComponent.java:982)
	at org.netbeans.core.io.ui.IOWindow$IOWindowImpl.updateWindowName(IOWindow.java:486)
	at org.netbeans.core.io.ui.IOWindow$IOWindowImpl.removeTab(IOWindow.java:358)
...
Comment 3 Martin Entlicher 2011-01-14 16:13:54 UTC
And the second exception should be fixed by the fix of issue #180960.

*** This bug has been marked as a duplicate of bug 180960 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo