Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 186654 - Two files with difference only in case are packaged in the build
Two files with difference only in case are packaged in the build
Status: VERIFIED FIXED
Product: ruby
Classification: Unclassified
Component: Platform
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Erno Mononen
issues@ruby
69patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-25 11:29 UTC by Petr Jiricka
Modified: 2010-07-08 13:16 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2010-05-25 11:29:49 UTC

    
Comment 1 Petr Jiricka 2010-05-25 11:36:33 UTC
The build zip archive contains two files whose name is almost identical but the case:
source.rb
source.RB

in directory:
netbeans/ruby/jruby-1.5.0/lib/ruby/gems/1.8/gems/ruby-debug-0.10.3/cli/ruby-debug/commands/

This causes problems when unpacking on some platforms, such as Windows or case-insensitive Mac drives.

This problem was introduced by the upgrade to JRuby 1.5 a week ago.
When I download the stock JRuby 1.5 installation, it only contains the lower-case source.rb file, not the upper-case source.RB file. So the problem is in the packaging process of JRuby into NetBeans.
Comment 2 Tomas Pavek 2010-05-25 12:03:16 UTC
The two files also have different content, looks like source.RB has some additional code. Don't we patch it and save with changed case?
Comment 3 Erno Mononen 2010-05-27 11:31:34 UTC
The source.rb and source.RB files are part of the ruby-debug-0.10.3 gem, which is now bundled with JRuby (as of 1.5). The gem provides command line debugging and is not under our control (i.e. is not part of debug-commons), so I can't fix the issue in the gem itself. I'll notify the gem owner about this. For 6.9 I can resolve the issue by removing the gem from the bundled JRuby; then it won't be possible to do cli debugging out-of-the-box, but I think we can live with that (that was the case before as well).
Comment 4 Petr Jiricka 2010-05-27 11:41:42 UTC
You are saying that this gem is a part of JRuby, but when I download the JRuby distribution from jruby.org, there is just one of these files. How is this possible? It looks like they somehow deal with this in JRuby.
Comment 5 Erno Mononen 2010-05-27 11:51:56 UTC
The files are in a .gem file, ruby-debug-0.10.3.gem to be specific - the gem is then installed (unpacked) as part of the build process.
Comment 6 Erno Mononen 2010-05-31 08:38:57 UTC
Fixed in 7aa4d2cb1670 by removing ruby-debug from the bundled JRuby. The two files are provided by the ruby-debug gem, but apparently it is somehow platform specific whether they both really get installed. Removing the gems seems like the best way to fix this for 6.9.
Comment 7 Erno Mononen 2010-05-31 08:45:59 UTC
I guess this should be transplanted to release69 if it is not too late, so raising the priority and adding the keyword.
Comment 8 Erno Mononen 2010-05-31 13:06:46 UTC
pchytil, can you please verify the issue so that this can be put to 6.9? Thanks.
Comment 9 Quality Engineering 2010-06-01 12:28:34 UTC
Integrated into 'main-golden', will be available in build *201006011333* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/7aa4d2cb1670
User: Erno Mononen <emononen@netbeans.org>
Log: #186654 - Two files with difference only in case are packaged in the build
Comment 10 Petr Chytil 2010-06-02 08:13:35 UTC
Finally, I was able to verify it in NetBeans-dev-web-main-3306-on-100601-full.zip which was the first build, which contains the fix. I also tried to unzip build 3304 and it still contained the error - that's ok.
Comment 11 Petr Chytil 2010-06-02 09:25:48 UTC
verified also in NetBeans IDE Dev (Build 201006020001)
Comment 12 Erno Mononen 2010-06-03 08:46:41 UTC
Transplanted to release69 in 65815be67d98.
Comment 13 rbalada 2010-06-14 07:51:11 UTC
Transplanted  to release691 as 7951ab367944

(Marking verified per Petr Chytil's comment)
Comment 14 rbalada 2010-06-14 08:38:07 UTC
Added keyword 6.9.1_CANDIDATE to bugfixes, which were integrated in release69 repository *after* the release691 clone has been created.
Comment 15 Tomas Danek 2010-07-08 13:16:32 UTC
do not see the mentioned gem in

Product Version: NetBeans IDE 6.9.1 Dev (Build 201007072301)
Java: 1.6.0_20; Java HotSpot(TM) 64-Bit Server VM 16.3-b01-279
System: Mac OS X version 10.6.4 running on x86_64; MacRoman; en_US (nb)
Userdir: /Users/Tomas/.netbeans/6.9.1dev

--> verified in 6.9.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo