Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 186588 - Number of JavaFX plugins available for Solaris SPARC
Number of JavaFX plugins available for Solaris SPARC
Status: RESOLVED WONTFIX
Product: updatecenters
Classification: Unclassified
Component: Beta
6.x
PC Solaris
: P1 (vote)
: 6.x
Assigned To: Martin Ryzl
Autoupdate Masters
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 09:04 UTC by Michael Nazarov
Modified: 2010-05-28 09:10 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (7.83 KB, image/png)
2010-05-24 09:21 UTC, Michael Nazarov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Nazarov 2010-05-24 09:04:44 UTC
There is no JavaFX support for Solaris SPARC platform, but there are three plugins available for install.
None of them installable because of error described on screenshot.
Comment 1 Jiri Kovalsky 2010-05-24 09:17:00 UTC
Michael, can you please attach the screenshot? Thanks!
Comment 2 Michael Nazarov 2010-05-24 09:21:20 UTC
Created attachment 99377 [details]
screenshot
Comment 3 Michael Nazarov 2010-05-24 09:21:57 UTC
Oops, sorry, looks like I missed attach during entering issue.
Comment 4 Jiri Kovalsky 2010-05-24 09:48:47 UTC
Robert, can you please discuss this problem with Martin Ryzl and suggest a solution? Thanks!
Comment 5 Martin Ryzl 2010-05-25 13:20:14 UTC
Please provide exact version numbers of the affected plugins. It may be an issue related to latest RC, however, the dependency looks rather old. I don't have Solaris so I depend on the information provided by you.
Comment 6 rnovak 2010-05-25 20:24:00 UTC
New version of JavaFX modules was published today. This could fix the problem, could you, please verify ?
Comment 7 Jiri Kovalsky 2010-05-26 07:17:14 UTC
Michael, any update on this? Thanks!
Comment 8 Michael Nazarov 2010-05-26 07:23:24 UTC
NetBeans Certified Plugin
 Version: 1.2.1 Author: Sun Microsystems Date: 4/20/10 Source: NetBeans Homepage: http://www.netbeans.org  
Plugin Description
JavaFX Composer allows users to visually design JavaFX application. Besides the layout designer it also offers new flow design based on application states and access to various data sources such as REST services, databases, local files, etc. Applications that consists of several screens now can be created in few clicks.

Version: 1.11.1 Date: 4/20/10 Source: NetBeans Homepage: http://javafx.netbeans.org/  
Plugin Description
The JavaFX Script Plugin for Netbeans provides JavaFX Script language support in the Netbeans IDE. The plugin provides JavaFX project type, editing capabilities such as code formatting, syntax highlighting, error detection, preview panel, etc.

Version: 1.8.1 Date: 4/20/10 Source: NetBeans Homepage: http://javafx.netbeans.org  
Plugin Description
Sample Application shows 2 days Weather forecast for 3 different cities using information from a real weather service.
Comment 9 Michael Nazarov 2010-05-26 07:24:47 UTC
JavaFX Composer
JavaFX Kit
JavaFX Weather Sample

respectively.
Comment 10 Martin Ryzl 2010-05-26 08:03:01 UTC
4/20 date means the plugins you see are definitely old. Now we have to investigate what build are you using, configuration of your UC client, ie. which update centers and their URLs.
Comment 11 Michael Nazarov 2010-05-26 08:05:20 UTC
Latest 6.9 RC1 from 24 May.
Comment 12 Jiri Kovalsky 2010-05-26 08:23:05 UTC
I am afraid that there is no way how to fix this issue. We could possibly create several binaries for these three samples which would then use OpenIDE-Module-Requires attribute to determine visibility on supported operating systems but:

* these modules would have conflicting values of codenamebase attributes and
* there is no way to differentiate Solaris SPARC from other platforms (x86, IA-32)

[1] http://bits.netbeans.org/dev/javadoc/org-openide-modules/org/openide/modules/doc-files/api.html#how-os-specific

Martine, do you have some other saving idea?
Comment 13 Michael Nazarov 2010-05-26 08:25:31 UTC
Why don't we just remove these three items from update center?
Comment 14 Michael Nazarov 2010-05-26 08:26:45 UTC
Sorry, I missed:
there is no way to differentiate Solaris SPARC from other platforms
Comment 15 Martin Ryzl 2010-05-26 09:05:24 UTC
The screenshot shows another issue - implementation dependency on other module. This issue has been solved some time ago. The old dates on modules likely indicate problems with the UC configuration.
Comment 16 Lukas Hasik 2010-05-26 09:45:23 UTC
from http://updates.netbeans.org/netbeans/updates/6.9/uc/final/stable/catalog.xml.gz
I cannot see any dependency on a module from 4/20 as shown in Michael's screenshot.  

IMO, the problem could be that there is an "old" module in your userdir. Could you try to start the IDE with fresh userdir?
Have you imported "old" userdir?


----------------------8<-------------------------------------------------------
<module autoload="false" codenamebase="org.netbeans.modules.javafx.profiler" distribution="modules/javafx/org-netbeans-modules-javafx-profiler.nbm" downloadsize="46320" eager="true" homepage="http://javafx.netbeans.org/" license="5450FDB0" moduleauthor="" needsrestart="false" releasedate="2010/05/25">
<manifest AutoUpdate-Show-In-Client="false" OpenIDE-Module="org.netbeans.modules.javafx.profiler" OpenIDE-Module-Display-Category="JavaFX" OpenIDE-Module-Implementation-Version="100524" OpenIDE-Module-Java-Dependencies="Java > 1.5" OpenIDE-Module-Long-Description="Add-on for NetBeans Profiler providing support for profiling JavaFX projects." OpenIDE-Module-Module-Dependencies="org.netbeans.api.java/1 > 1.13, org.netbeans.api.java.classpath/1 > 1.18, org.netbeans.lib.profiler/1 > 1.1, org.netbeans.lib.profiler.common/1 > 1.1, org.netbeans.lib.profiler.ui/1 > 1.2, org.netbeans.modules.editor.lib2/1 > 1.6, org.netbeans.modules.java.platform/1 > 1.9, org.netbeans.modules.java.source > 0.31, org.netbeans.modules.javafx.editor > 1.8.1, org.netbeans.modules.javafx.platform > 1.7.1, org.netbeans.modules.javafx.project = 100524, org.netbeans.modules.javafx.source > 1.7.1, org.openide.util.lookup > 8.0.0.1, org.netbeans.modules.profiler/1 > 1.6, org.netbeans.modules.profiler.attach/1 > 1.0, org.netbeans.modules.profiler.projectsupport > 1.0, org.netbeans.modules.profiler.selector.spi/1 > 1.4, org.netbeans.modules.project.ant/1 > 1.16, org.netbeans.modules.projectapi/1 > 1.13, org.openide.dialogs > 7.5, org.openide.filesystems > 7.3, org.openide.loaders > 6.4, org.openide.modules > 7.3, org.openide.nodes > 7.0.1, org.openide.text > 6.21, org.openide.util > 7.9, org.netbeans.modules.java.api.common/0 = 201005242201, org.openide.awt > 6.10.0.1" OpenIDE-Module-Name="JavaFX Profiler" OpenIDE-Module-Requires="org.openide.modules.ModuleFormat1" OpenIDE-Module-Short-Description="JavaFX profiler" OpenIDE-Module-Specification-Version="1.9"/>
</module>
Comment 17 Michael Nazarov 2010-05-26 10:12:44 UTC
I always use clean machine because I also test installer/uninstaller :)
Yes, this is situation without old userdir in any way.

Anyway feel free to check it, I don't believe we have only one Solaris SPARC machine available!
Comment 18 Petr Chytil 2010-05-26 11:27:09 UTC
I have just tried this scenario on a SunRay:
----------------------8<----------------------
bash-3.00$ uname -a
SunOS sr1-eprg06-09 5.10 Generic_138888-08 sun4v sparc SUNW,Sun-Fire-T200
----------------------8<----------------------

NetBeans build was 6.9/rc1/2010-05-24_22-01-15 (official RC1) Java SE edition. Then, I have installed JavaFX Composer plugin from the update center. Installation did not show any errors, then I performed IDE restart.
When IDE started again, I have created Java FX Desktop Business Application project, added a Button to the scene and performed Run Main Project action. Again, no errors, this is content of the output window:
----------------------8<----------------------
init:
deps-jar:
compile:
jar:
standard-run:
Java Accessibility Bridge for GNOME loaded.

/usr/share/themes/Simple/gtk-2.0/gtkrc:46: Engine "thinice" is unsupported, ignoring
/usr/share/themes/Simple/gtk-2.0/gtkrc:53: Engine "redmond95" is unsupported, ignoring
/usr/share/themes/Simple/gtk-2.0/gtkrc:57: Engine "redmond95" is unsupported, ignoring
/usr/share/themes/Simple/gtk-2.0/gtkrc:46: Engine "thinice" is unsupported, ignoring
/usr/share/themes/Simple/gtk-2.0/gtkrc:53: Engine "redmond95" is unsupported, ignoring
/usr/share/themes/Simple/gtk-2.0/gtkrc:57: Engine "redmond95" is unsupported, ignoring
browser-run:
jws-run:
midp-run:
tv-run:
run:
BUILD SUCCESSFUL (total time: 39 seconds)
----------------------8<----------------------

Created application then started normally.
Comment 19 Lukas Hasik 2010-05-26 11:29:58 UTC
Michael, could you
1, check URL of UC - Tools > Plugins > Settings > NetBeans >URL
2, check from what UC the "JavaFX kit" is coming 
3, what build did you install?
Comment 20 Michael Nazarov 2010-05-26 11:47:07 UTC
1. http://updates.netbeans.org/netbeans/updates/6.9/uc/final/stable/catalog.xml.gz
2. NetBeans, described at [1]
3. NetBeans IDE 6.9 RC1 (Build 201005242201)
Comment 21 Lukas Hasik 2010-05-26 15:06:53 UTC
ok, as I still think that there have to be a mess on the machine or i n your userdir, could we investigate the bug. Or could you?

1, check what you can see in the http://updates.netbeans.org/netbeans/updates/6.9/uc/final/stable/catalog.xml for codenamebase="org.netbeans.modules.javafx.profiler"
Why? There can be a stupid cache providing you old content...

2, run the IDE with --userdir "some-path" and install the FX. I know that you've sad that it is clean machine but just to be sure ;)

3, attach messages.log
Comment 22 Michael Nazarov 2010-05-26 15:18:55 UTC
I don't think there is cache or something like this -- too sophisticated :)
Anyway will run with specified path to userdir.
Comment 23 Michael Nazarov 2010-05-27 08:08:09 UTC
As I found there were some changes on update center so now four fx plugins available and all of them installable -- I did it successfully.

So the only question for now -- should these plugins be available for SPARC platform or no.
Comment 24 Martin Ryzl 2010-05-27 08:29:23 UTC
Although it seems at least basic stuff works on Solaris SPARC (as verified by Petr Chytil), to be consistent with JavaFX supported platforms only Solaris x86 should be visible. I'm not sure this can be easily fixed for 6.9.
Comment 25 Lukas Hasik 2010-05-27 12:26:48 UTC
there is no way to differenciate between solaris sparc and solaris x86 now. It could be reported as new improvement for UC and module system.

I'm closing this bug as it isn't reproducible anymore
Comment 26 Michael Nazarov 2010-05-27 12:30:37 UTC
There are number of plugins -- why not reproducible?
Will not fix is better status.
Comment 27 Michael Nazarov 2010-05-28 09:10:28 UTC
BTW RC2 affected again -- it's not possible to install JavaFX plugins.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo