Bug 18652 - I18N - Can't Synchronize "Encoding" property and "contentType" value
I18N - Can't Synchronize "Encoding" property and "contentType" value
Status: RESOLVED DUPLICATE of bug 7427
Product: javaee
Classification: Unclassified
Component: Code
3.x
Sun Solaris
: P2 (vote)
: 3.x
Assigned To: Petr Jiricka
issues@javaee
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-14 13:34 UTC by Keiichi Oono
Modified: 2003-12-11 14:27 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Keiichi Oono 2001-12-14 13:34:50 UTC
When user change the "Encoding" property for JSP editing, the contentType value
is changed automatically.
Could you add this feature for JSP editing?

If user change "Content Language" property, it is better to change contentType
from "text/html" to "text/plain". And if user change "Encoding" property, it is
better to change contentType value from "text/xxxx; charset=yyyy". If the
Encoding value is null, the contentType can be "text/xxxx" (xxxx is equal to
"Content Language" setting.

Could you investigate the possibility to have this feature?
Comment 1 Ken Frank 2002-03-19 01:50:58 UTC
This would be very helpful for user in other locales
of English release and for localized release as well.
That's why I'm putting at P2.

ken.frank@sun.com
03/18/2002
Comment 2 Marek Grummich 2002-07-22 12:08:16 UTC
Set target milestone to TBD
Comment 3 Marek Grummich 2002-07-22 12:16:19 UTC
Set target milestone to TBD
Comment 4 Ken Frank 2002-10-12 19:34:31 UTC
Changing to defect after consulation with nb QA and comments from nb
strategy that some i18n rfes could actually be viewed as defects. 
It was thought that this one met that criteria.
Let me know if more details are needed.
ken.frank@sun.com
Comment 5 _ rkubacki 2002-11-27 16:24:43 UTC
That one is really RFE (or feature) not a bug. Targeting for NB4 and
reassigning to Petr. It looks that JspDataObject should be responsible
for this.
Comment 6 Jesse Glick 2002-12-23 16:36:40 UTC
Consistent use of the I18N keyword.
Comment 7 Petr Jiricka 2003-07-14 09:31:42 UTC
As for the Content Language property, I suggest it is removed (isn't
it already removed ?)

As for the Encoding property, would the solution proposed for issue
7427 also sufficiently address this enhancement request?
Comment 8 Keiichi Oono 2003-07-14 10:59:47 UTC
Yes, Content Language property has been removed already. I agree with
you that this RFE can be resolved as duplicate of issue 7427.
Comment 9 Petr Jiricka 2003-12-05 10:20:33 UTC
Resolving as duplicate of 7427.

*** This issue has been marked as a duplicate of 7427 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo