Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 186503 - Build on remote host fail
Build on remote host fail
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Remote
7.0
PC Windows 7 x64
: P3 (vote)
: 6.x
Assigned To: Vladimir Kvashin
issues@cnd
69patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-21 12:29 UTC by micheleg
Modified: 2010-07-09 14:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
The fixed script (2.78 KB, text/plain)
2010-06-07 06:19 UTC, Vladimir Kvashin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description micheleg 2010-05-21 12:29:28 UTC
Overview:
When I build my C project on a particular remote host I get this error message:

Copying project files to /root/.netbeans/remote/istech09-Windows-x86/ at root@192.168.0.191:22
/bin/sh: line 4: /var/tmp/dlight_root/55856f2c/tools/Linux-unknown/rfs_controller: No such file or directory
/bin/sh: line 4: exec: /var/tmp/dlight_root/55856f2c/tools/Linux-unknown/rfs_controller: cannot execute: No such file or directory
Error copying project files to /root/.netbeans/remote/istech09-Windows-x86/ at root@192.168.0.191:22: 
Remote controller failed; rc=126

Steps to reproduce:
1) Select the project and build.

Tested on development IDE version 201005192201.

Additional info:
The problem is connected only to a particular remote host. I made some tests with other systems and I think that the problem is due to the fact that this remote host is not a genuine Intel processor but only a x86 compatible (I note the "Linux-unknown" directory in the error message!). My uname -a reports:

Linux sx100c 2.6.27.7-smp #2 SMP Thu Nov 20 22:32:43 CST 2008 i686 VIA Eden
Processor 1000MHz CentaurHauls GNU/Linux
Comment 1 Vladimir Kvashin 2010-05-21 13:01:22 UTC
What does uname -p and uname -m say on your remote machine?
Comment 2 Vladimir Kvashin 2010-05-21 13:12:24 UTC
There is a workaround: you can hack the following file 
${NBDIST}/ide/bin/nativeexecution/hostinfo.sh
(where ${NBDIST} stands for NetBeans installation directory).

This script determines remote host properties. The key lines for cpu type are

CPUTYPE=`uname -p`
if [ "${CPUTYPE}" = "unknown" ]; then
   CPUTYPE=`uname -m`
fi
CPUFAMILY=`(echo ${CPUTYPE} | egrep "^i|x86_64|athlon|Intel" >/dev/null && echo x86) || echo ${CPUTYPE}`

If you tune the script so that CPUFAMILY is set to "x86" for your host, remote should work, I believe.
Comment 3 micheleg 2010-05-21 14:21:22 UTC
here is what uname say:

root@sx100c:~# uname -p
VIA Eden Processor 1000MHz
root@sx100c:~# uname -m
i686

and this is the output of the script hostinfo.sh executed on remote host:

root@sx100c:~# sh hostinfo.sh
BITNESS=32
CPUFAMILY=VIA Eden Processor 1000MHz
CPUNUM=1
CPUTYPE=VIA Eden Processor 1000MHz
HOSTNAME=sx100c
OSNAME=
OSBUILD=
OSFAMILY=LINUX
USER=root
SH=/bin/bash
USERDIRBASE=/root
TMPDIRBASE=/var/tmp/dlight_root/
DATETIME=2010-05-21 14:11:18
ENVFILE=/var/tmp/dlight_root//env

I tried to modify the script in the nativeexecution directory but it doesn't work. Even forcing CPUFAMILY=x86 I get the same error (with the "Linux-unknown" directory). Naturally I delete and recreate remote host in the Host Manager.
Comment 4 Vladimir Kvashin 2010-06-07 06:14:57 UTC
I believe it is now fixed (in cnd-main):
http://hg.netbeans.org/cnd-main/rev/272cdc06fedb
Comment 5 Vladimir Kvashin 2010-06-07 06:19:46 UTC
Created attachment 99850 [details]
The fixed script

I'm attaching the fixed script, so you don't have to wait until my changes are in development build.

Could you please replace your hostinfo.sh with the attached file and check whether it works on your machine? If not, please reopen this issue.
Comment 6 micheleg 2010-06-07 17:05:34 UTC
I just tested the script on the Dev IDE build 201006050001. It works perfectly!

In the next days I will try this IDE in a production environment.

Thank you very much.
Comment 7 Quality Engineering 2010-06-08 06:06:12 UTC
Integrated into 'main-golden', will be available in build *201006080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/272cdc06fedb
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: fixed #186503 -  Build on remote host fail
Comment 8 rbalada 2010-06-16 08:54:14 UTC
Please verify bugfix for this bug, so it can be included in release691 repository.

Thanks,
-R
Comment 9 Alexander Pepin 2010-06-18 11:40:21 UTC
verified by user micheleg
Comment 10 rbalada 2010-06-21 15:26:59 UTC
main #272cdc06fedb transplanted to release691 #305dae94dab3
Comment 11 Alexander Pepin 2010-07-09 14:29:08 UTC
verified in 6.9.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo