Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 186476 - Introduce method (and other refactoring) shortcuts stopped working
Introduce method (and other refactoring) shortcuts stopped working
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Hints
7.0
PC Linux
: P3 with 1 vote (vote)
: 7.0
Assigned To: Jan Lahoda
issues@java
69patch1-verified
:
: 187929 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-21 07:46 UTC by dlichtenberger
Modified: 2010-07-08 05:28 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dlichtenberger 2010-05-21 07:46:17 UTC
With 6.9 Beta 1 some refactoring shortcuts stopped working for me, e.g. Introduce Method. When I select the refactoring from the context menu, it works as expected. 

I'm using the IDEA keymap, but it also doesn't work when switching back to the Netbeans keymap. I don't know if it affects this, but no shortcut is displayed in the context menu (IIRC NB 6.8 didn't have these either, but the shortcuts worked anyway). The problem still exists with a recent snapshot (201005192201).
Comment 1 Jan Lahoda 2010-05-24 14:49:16 UTC
Lets see if this will work correctly:
http://hg.netbeans.org/jet-main/rev/1056a0707ab2
Comment 2 Quality Engineering 2010-05-25 07:33:52 UTC
Integrated into 'main-golden', will be available in build *201005250001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/1056a0707ab2
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #186476: trying to make Introduce something shortcuts work+show them in main menu and editor context menu.
Comment 3 dlichtenberger 2010-06-11 07:37:36 UTC
Thanks for the quick fix! I noticed that this didn't make it into 6.9 RC2. Will this be integrated into 6.9 eventually?
Comment 4 Jan Lahoda 2010-06-13 18:23:50 UTC
Sorry, the patch will not be part of NB6.9. I am marking it as a candidate for 6.9.1 patch release though.
Comment 5 rbalada 2010-06-16 08:54:11 UTC
Please verify bugfix for this bug, so it can be included in release691 repository.

Thanks,
-R
Comment 6 dlichtenberger 2010-06-16 09:56:17 UTC
I'm using an older 6.9 Snapshot (201005250001), it works fine there.
Comment 7 Petr Blaha 2010-06-17 11:51:43 UTC
verified
Comment 8 rbalada 2010-06-21 13:34:57 UTC
main #1056a0707ab2 transplanted to release691 #d329b6965826
Comment 9 Jan Lahoda 2010-06-25 07:47:12 UTC
*** Bug 187929 has been marked as a duplicate of this bug. ***
Comment 10 Martin Fousek 2010-07-08 05:28:23 UTC
Verified in NetBeans IDE 6.9.1 Dev (Build 201007062301).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo