Bug 186402 - project properties for freeform project open on non-existent display, unreachable
project properties for freeform project open on non-existent display, unreach...
Status: RESOLVED DUPLICATE of bug 187608
Product: projects
Classification: Unclassified
Component: Ant Freeform
6.x
PC Windows Vista
: P3 (vote)
: 7.0
Assigned To: Tomas Zezula
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 18:27 UTC by julch
Modified: 2011-11-16 16:46 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description julch 2010-05-19 18:27:36 UTC
problem is propably identical to this forum post about NB6.7:
http://forums.netbeans.org/post-42860.html

Problem:
When i tried to open project properties of a freeform or nbandroid project, nothing seemed to happen:
no dialog popping up, and focus was still on the main netbeans window.

For "regular" Java Project types like "java se" and "java me" everything worked normal, i.e. the properties window appeared as expected.

Probable cause:
I use my laptop display in combination with an external display.
Because of changing workspaces, the external monitor sits sometimes "to the right" and sometimes "to the left" of the laptop display.

Netbeans seems to "remember" the position the dialog was on before, even if that position is not visible with the current display configuration.

Workaraound:
As soon as I "switched positions" of my displays, the missing dialogs appeared on the display that did not contain the main netbeans window.

I suppose Netbeans needs to check the position of Dialogs to make sure they are valid in the current display setup.
Comment 1 _ wadechandler 2010-07-22 02:43:22 UTC
Marking as a duplicate of issue 187608 as there is more information in that issue. This is common to the generic project UI API support. See issue 187608 for more details.

*** This bug has been marked as a duplicate of bug 187608 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo