Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 186297 - NullPointerException: Null child at index 0, parent: Root, model: org.netbeans.spi.viewmodel.Models$CompoundModel@434bb370 TreeModel = org.netbeans.spi.viewmodel.Models$CompoundTreeModel@59ac9e80
NullPointerException: Null child at index 0, parent: Root, model: org.netbean...
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
EXCEPTIONS_REPORT 69patch1
:
: 186486 189283 190836 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 13:11 UTC by Marian Mirilovic
Modified: 2010-10-14 14:59 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.69 KB, text/plain)
2010-05-18 13:11 UTC, Marian Mirilovic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2010-05-18 13:11:10 UTC
Build: NetBeans IDE Dev (Build trunk-8442-on-100518)
VM: Java HotSpot(TM) 64-Bit Server VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Linux

User Comments:
GUEST: Starting java debugger

GUEST: Stopping java debugger

mmirilovic: Steps to reproduce:
- I had opened MemoryView project
- CLass breakpoint in group 'xxxx' and another line breakpoint inside constructor
- started debugger
- slected Breakpoint's group node 'xxx' and pushed 'Delete All' from context menu
- continue in debugging

GUEST: Stopping java debugging and clicking in editor window




Stacktrace: 
java.lang.NullPointerException: Null child at index 0, parent: Root, model: org.netbeans.spi.viewmodel.Models$CompoundModel@434bb370
  TreeModel = org.netbeans.spi.viewmodel.Models$CompoundTreeModel@59ac9e80
    org.netbeans.modules.debugger.jpda.projects.ToolTipTreeModelFilter@1461f52d
      org.netbeans.modules.debugger.jpda.ui.models.VariablesTreeModelFilter@7bdbb584
        org.netbeans.modules.debugger.jpda.ui.models.VariablesTreeModelFilterSI@6d988c50
          org.netbeans.spi.viewmodel.Models$DelegatingTreeModel@1ef1a094
    org.netbeans.modules.debugger.jpda.models.LocalsTreeModel@4cc6376a
  NodeModel = org.netbeans.spi.viewmodel.Models$CompoundNodeModel@1235e034
    org.netbeans.modules.debugger.jpda.projects.ToolTipNodeModelFilter@28105d2b
      org.netbeans.modules.debugger.jpda.ui.models.VariablesTreeModelFilter@7bdbb584
        org.netbeans.modules.debugger.jpda.ui.models.VariablesNodeModel@678b3c06
        org.netbeans.modules.debugger.jpda.ui.models.VariablesTreeModelFilterSI@6d988c50
  TableM
   at org.netbeans.modules.viewmodel.TreeModelNode$TreeModelChildren.applyChildren(TreeModelNode.java:1377)
   at org.netbeans.modules.viewmodel.TreeModelNode$TreeModelChildren.refreshLazyChildren(TreeModelNode.java:1353)
   at org.netbeans.modules.viewmodel.TreeModelNode$TreeModelChildren.refreshChildren(TreeModelNode.java:1213)
   at org.netbeans.modules.viewmodel.TreeModelNode.refreshTheChildren(TreeModelNode.java:820)
   at org.netbeans.modules.viewmodel.TreeModelNode.refreshTheChildren(TreeModelNode.java:803)
   at org.netbeans.modules.viewmodel.TreeModelNode$5.run(TreeModelNode.java:546)
Comment 1 Marian Mirilovic 2010-05-18 13:11:13 UTC
Created attachment 99131 [details]
stacktrace
Comment 2 Marian Mirilovic 2010-05-18 13:12:49 UTC
Once again - correct steps to reproduce:
- I had opened MemoryView project
- CLass breakpoint in group 'xxxx' and another line breakpoint inside
constructor
- started debugger
- slected Breakpoint's group node 'xxx' and pushed 'Delete All' from context
menu
- continue in debugging
- finish debugging session (close the debugging application)
-> exception rises
Comment 3 Martin Entlicher 2010-05-18 13:32:07 UTC
Most likely a bug in ToolTipTreeModelFilter
Comment 4 Martin Entlicher 2010-05-18 13:53:01 UTC
Fixed in changeset:   171400:06c2243b9ea7
http://hg.netbeans.org/main/rev/06c2243b9ea7
Comment 5 Martin Entlicher 2010-05-18 22:32:10 UTC
It did not get into release69.
Comment 6 Martin Entlicher 2010-05-21 12:26:14 UTC
*** Bug 186486 has been marked as a duplicate of this bug. ***
Comment 7 Marian Mirilovic 2010-05-21 13:12:12 UTC
verified in NB dev (201005210001)

... adding sw : 69patch-candidate - just to reevaluate for patch integration once we'll plan for it, based on number of duplicates (reports)
Comment 8 pgebauer 2010-06-03 09:31:18 UTC
The fix has been ported into the release691 branch
http://hg.netbeans.org/release691/rev/2b3a52b8c1c2
Comment 9 Martin Entlicher 2010-08-09 10:10:52 UTC
*** Bug 189283 has been marked as a duplicate of this bug. ***
Comment 10 Martin Entlicher 2010-10-14 14:59:21 UTC
*** Bug 190836 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo