Bug 186279 - NoSuchMethodError: org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Ljava/util/concurrent/Callable;)Ljava/lang/Object;
NoSuchMethodError: org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(...
Status: RESOLVED DUPLICATE of bug 186233
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 07:41 UTC by Exceptions Reporter
Modified: 2010-05-18 10:24 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.97 KB, text/plain)
2010-05-18 07:41 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2010-05-18 07:41:12 UTC
Build: NetBeans IDE Dev (Build 201004270201)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Windows 7

User Comments:
b166er: created empty new project: "new project with existing source"




Stacktrace: 
java.lang.NoSuchMethodError: org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Ljava/util/concurrent/Callable;)Ljava/lang/Object;
   at org.netbeans.modules.java.source.usages.ClassIndexManager.takeWriteLock(ClassIndexManager.java:147)
   at org.netbeans.modules.java.source.indexing.JavaBinaryIndexer$Factory$2.run(JavaBinaryIndexer.java:166)
   at org.netbeans.modules.java.source.indexing.JavaBinaryIndexer$Factory$2.run(JavaBinaryIndexer.java:164)
   at org.netbeans.modules.java.source.usages.ClassIndexManager.prepareWriteLock(ClassIndexManager.java:114)
   at org.netbeans.modules.java.source.indexing.JavaBinaryIndexer$Factory.scanStarted(JavaBinaryIndexer.java:164)
   at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.binaryScanStarted(RepositoryUpdater.java:1755)
Comment 1 Exceptions Reporter 2010-05-18 07:41:16 UTC
Created attachment 99116 [details]
stacktrace
Comment 2 David Strupl 2010-05-18 08:29:17 UTC
This error usually means that you have wrong build. Please fetch a proper build or do clean and build if you are building yourself.
Comment 3 Vitezslav Stejskal 2010-05-18 10:24:11 UTC

*** This bug has been marked as a duplicate of bug 186233 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo