Bug 186084 - java.io.IOException: #184196: refusing to open http://kenai-test.czech.sun.com:8180/job/jara-jira/ws/nbproject/build-impl.xml from EQ
java.io.IOException: #184196: refusing to open http://kenai-test.czech.sun.co...
Status: RESOLVED DUPLICATE of bug 207478
Product: platform
Classification: Unclassified
Component: Text
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@editor
issues@editor
EXCEPTIONS_REPORT
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 11:36 UTC by Jaromir Uhrik
Modified: 2012-10-11 07:29 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.78 KB, text/plain)
2010-05-13 11:36 UTC, Jaromir Uhrik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2010-05-13 11:36:44 UTC
Build: NetBeans IDE Dev (Build 201005122200)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.3-b01-101, Java(TM) SE Runtime Environment, 1.6.0_17-b04-248-9M3125
OS: Mac OS X

User Comments:
juhrik: Exception appeared suddenly...




Stacktrace: 
java.io.IOException: #184196: refusing to open http://kenai-test.czech.sun.com:8180/job/jara-jira/ws/nbproject/build-impl.xml from EQ
   at org.netbeans.modules.hudson.api.ConnectionBuilder.connection(ConnectionBuilder.java:216)
   at org.netbeans.modules.hudson.impl.RemoteFileSystem.connection(RemoteFileSystem.java:205)
   at org.netbeans.modules.hudson.impl.RemoteFileSystem.inputStreamNoCache(RemoteFileSystem.java:323)
   at org.netbeans.modules.hudson.impl.RemoteFileSystem.access$100(RemoteFileSystem.java:78)
   at org.netbeans.modules.hudson.impl.RemoteFileSystem$1HeaderCachedInputStream.read(RemoteFileSystem.java:292)
   at java.io.InputStream.read(InputStream.java:154)
Comment 1 Jaromir Uhrik 2010-05-13 11:36:47 UTC
Created attachment 98928 [details]
stacktrace
Comment 2 Jesse Glick 2010-05-13 14:41:29 UTC
I suppose the editor should not be reading file content from EQ, but I'm not sure exactly how this works. I have not seen such an exception opening remote workspace files in the editor; perhaps this only occurs after a reload of an open document?

(Background: the Hudson module is just throwing an IOE rather than risk hanging the GUI waiting for a slow or dead network connection. It would be nice to be able to add a timeout on the HTTPURLConnection, but the API which supposedly does this does not seem to work at all.)
Comment 3 David Strupl 2012-10-11 07:29:20 UTC

*** This bug has been marked as a duplicate of bug 207478 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo