Bug 186001 - [69cat] Deadlock during POM.xml edition
[69cat] Deadlock during POM.xml edition
Status: RESOLVED DUPLICATE of bug 185923
Product: projects
Classification: Unclassified
Component: Maven
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: David Simonek
issues@projects
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 12:29 UTC by jmborer
Modified: 2010-05-12 14:41 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jmborer 2010-05-12 12:29:39 UTC
[ BUILD # : 201004200117 ]
[ JDK VERSION : 1.6.* ]

This is what VisualVM reported

Found one Java-level deadlock:
=============================
"Default RequestProcessor":
  waiting to lock monitor 0x07ee9be4 (object 0x1aec1f70, a
org.netbeans.modules.xml.xdm.XDMModel),
  which is held by "Default RequestProcessor"
"Default RequestProcessor":
  waiting to lock monitor 0x0839796c (object 0x1f3f1f58, a
org.netbeans.modules.maven.model.pom.impl.ProjectImpl),
  which is held by "AWT-EventQueue-1"
"AWT-EventQueue-1":
  waiting to lock monitor 0x07ee9be4 (object 0x1aec1f70, a
org.netbeans.modules.xml.xdm.XDMModel),
  which is held by "Default RequestProcessor"

Java stack information for the threads listed above:
===================================================
"Default RequestProcessor":
	at org.netbeans.modules.xml.xdm.XDMModel.getDocument(XDMModel.java:824)
	- waiting to lock <0x1aec1f70> (a org.netbeans.modules.xml.xdm.XDMModel)
	at
org.netbeans.modules.xml.xdm.xam.XDMAccess.getContainingElement(XDMAccess.java:3
94)
	at
org.netbeans.modules.xml.xdm.xam.XDMAccess.getContainingElement(XDMAccess.java:7
9)
	at
org.netbeans.modules.xml.xam.dom.AbstractDocumentModel.findComponent(AbstractDoc
umentModel.java:492)
	at
org.netbeans.modules.maven.navigator.POMModelPanel.updateCaret(POMModelPanel.jav
a:566)
	at
org.netbeans.modules.maven.navigator.POMModelPanel.access$100(POMModelPanel.java
:111)
	at
org.netbeans.modules.maven.navigator.POMModelPanel$1.run(POMModelPanel.java:123)

	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1369)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1907)
"Default RequestProcessor":
	at
org.netbeans.modules.xml.xam.AbstractComponent.getModel(AbstractComponent.java:2
23)
	- waiting to lock <0x1f3f1f58> (a
org.netbeans.modules.maven.model.pom.impl.ProjectImpl)
	at
org.netbeans.modules.xml.xam.dom.AbstractDocumentComponent.getModel(AbstractDocu
mentComponent.java:426)
	at
org.netbeans.modules.maven.model.pom.impl.POMComponentImpl.getModel(POMComponent
Impl.java:75)
	at
org.netbeans.modules.maven.model.pom.impl.POMComponentImpl.getModel(POMComponent
Impl.java:61)
	at
org.netbeans.modules.xml.xam.dom.AbstractDocumentComponent.referencesSameNode(Ab
stractDocumentComponent.java:430)
	at
org.netbeans.modules.xml.xam.dom.AbstractDocumentModel.findComponent(AbstractDoc
umentModel.java:470)
	at
org.netbeans.modules.xml.xam.dom.AbstractDocumentModel.findComponent(AbstractDoc
umentModel.java:462)
	at
org.netbeans.modules.xml.xam.dom.AbstractDocumentModel.prepareSyncUnit(AbstractD
ocumentModel.java:286)
	at
org.netbeans.modules.xml.xdm.xam.XDMListener.processChange(XDMListener.java:140)

	at
org.netbeans.modules.xml.xdm.xam.XDMListener.processEvent(XDMListener.java:212)
	at
org.netbeans.modules.xml.xdm.xam.XDMListener.propertyChange(XDMListener.java:226
)
	at
java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:3
39)
	at
java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:2
76)
	at org.netbeans.modules.xml.xdm.XDMModel.fireDiffEvents(XDMModel.java:269)
	at org.netbeans.modules.xml.xdm.XDMModel.finishSync(XDMModel.java:221)
	at org.netbeans.modules.xml.xdm.XDMModel.sync(XDMModel.java:158)
	- locked <0x1aec1f70> (a org.netbeans.modules.xml.xdm.XDMModel)
	at org.netbeans.modules.xml.xdm.xam.XDMAccess.sync(XDMAccess.java:143)
	- locked <0x1aec1f70> (a org.netbeans.modules.xml.xdm.XDMModel)
	at org.netbeans.modules.xml.xam.AbstractModel.sync(AbstractModel.java:259)
	- locked <0x1ae98238> (a
org.netbeans.modules.maven.model.pom.impl.POMModelImpl)
	at
org.netbeans.modules.maven.hints.pom.StatusProvider$StatusProviderImpl.findHints
(StatusProvider.java:133)
	at
org.netbeans.modules.maven.hints.pom.StatusProvider$StatusProviderImpl.checkHint
s(StatusProvider.java:124)
	at
org.netbeans.modules.maven.hints.pom.StatusProvider$StatusProviderImpl.access$00
0(StatusProvider.java:96)
	at
org.netbeans.modules.maven.hints.pom.StatusProvider$StatusProviderImpl$1$1.run(S
tatusProvider.java:109)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1369)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1907)
"AWT-EventQueue-1":
	at org.netbeans.modules.xml.xdm.XDMModel.getDocument(XDMModel.java:824)
	- waiting to lock <0x1aec1f70> (a org.netbeans.modules.xml.xdm.XDMModel)
	at
org.netbeans.modules.xml.xdm.nodes.NodeImpl.getNamespaceURI(NodeImpl.java:601)
	at
org.netbeans.modules.maven.model.pom.impl.POMComponentFactoryImpl.getQName(POMCo
mponentFactoryImpl.java:63)
	at
org.netbeans.modules.maven.model.pom.impl.POMComponentFactoryImpl.create(POMComp
onentFactoryImpl.java:81)
	at
org.netbeans.modules.maven.model.pom.impl.POMComponentFactoryImpl.create(POMComp
onentFactoryImpl.java:51)
	at
org.netbeans.modules.maven.model.pom.impl.POMComponentImpl.populateChildren(POMC
omponentImpl.java:87)
	at
org.netbeans.modules.xml.xam.AbstractComponent._getChildren(AbstractComponent.ja
va:180)
	- locked <0x1f3f1f58> (a
org.netbeans.modules.maven.model.pom.impl.ProjectImpl)
	at
org.netbeans.modules.xml.xam.AbstractComponent.getChildren(AbstractComponent.jav
a:196)
	- locked <0x1f3f1f58> (a
org.netbeans.modules.maven.model.pom.impl.ProjectImpl)
	at
org.netbeans.modules.maven.model.pom.impl.POMComponentImpl.getChildElementText(P
OMComponentImpl.java:157)
	at
org.netbeans.modules.maven.model.pom.impl.ProjectImpl.getModelVersion(ProjectImp
l.java:455)
	at
org.netbeans.modules.maven.navigator.POMModelVisitor.visit(POMModelVisitor.java:
158)
	at sun.reflect.GeneratedMethodAccessor105.invoke(Unknown Source)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.jav
a:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at
org.netbeans.modules.maven.navigator.POMModelVisitor$PomChildren.rescan(POMModel
Visitor.java:1448)
	at
org.netbeans.modules.maven.navigator.POMModelVisitor$PomChildren.addNotify(POMMo
delVisitor.java:1431)
	at org.openide.nodes.Children.callAddNotify(Children.java:550)
	at org.openide.nodes.EntrySupport$Default.getArray(EntrySupport.java:744)
	at org.openide.nodes.EntrySupport$Default.getNodes(EntrySupport.java:166)
	at org.openide.nodes.EntrySupport$Default.getNodes(EntrySupport.java:222)
	at org.openide.nodes.EntrySupport$Default.getNodesCount(EntrySupport.java:226)
	at org.openide.nodes.Children.getNodesCount(Children.java:484)
	at
org.openide.explorer.view.VisualizerNode.getChildren(VisualizerNode.java:255)
	at
org.openide.explorer.view.VisualizerNode.getChildren(VisualizerNode.java:245)
	at
org.openide.explorer.view.VisualizerNode.getChildCount(VisualizerNode.java:322)
	at javax.swing.tree.DefaultTreeModel.getChildCount(DefaultTreeModel.java:168)
	at
javax.swing.tree.FixedHeightLayoutCache$FHTreeStateNode.expand(FixedHeightLayout
Cache.java:1135)
	at
javax.swing.tree.FixedHeightLayoutCache.rebuild(FixedHeightLayoutCache.java:600)

	at
javax.swing.tree.FixedHeightLayoutCache.treeStructureChanged(FixedHeightLayoutCa
che.java:472)
	at
javax.swing.plaf.basic.BasicTreeUI$Handler.treeStructureChanged(BasicTreeUI.java
:3824)
	at
javax.swing.tree.DefaultTreeModel.fireTreeStructureChanged(DefaultTreeModel.java
:561)
	at
javax.swing.tree.DefaultTreeModel.nodeStructureChanged(DefaultTreeModel.java:347
)
	at javax.swing.tree.DefaultTreeModel.setRoot(DefaultTreeModel.java:117)
	at org.openide.explorer.view.NodeTreeModel$1.run(NodeTreeModel.java:113)
	at org.openide.util.Mutex.doEvent(Mutex.java:1335)
	at org.openide.util.Mutex.readAccess(Mutex.java:345)
	at org.openide.explorer.view.NodeTreeModel.setNode(NodeTreeModel.java:99)
	at
org.openide.explorer.view.TreeView.synchronizeRootContext(TreeView.java:839)
	at
org.openide.explorer.view.TreeView$TreePropertyListener$1.run(TreeView.java:1223
)
	at org.openide.util.Mutex.readAccess(Mutex.java:362)
	at org.openide.util.Mutex$1R.run(Mutex.java:1301)
	at org.openide.util.Mutex.doWrapperAccess(Mutex.java:1318)
	at org.openide.util.Mutex.readAccess(Mutex.java:351)
	at
org.openide.explorer.view.TreeView$TreePropertyListener.propertyChange(TreeView.
java:1219)
	at
org.openide.util.WeakListenerImpl$PropertyChange.propertyChange(WeakListenerImpl
.java:188)
	at
java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:3
39)
	at
java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:2
76)
	at org.openide.explorer.ExplorerManager$2.run(ExplorerManager.java:865)
	at org.openide.util.Mutex.doEvent(Mutex.java:1335)
	at org.openide.util.Mutex.readAccess(Mutex.java:345)
	at org.openide.explorer.ExplorerManager.fireInAWT(ExplorerManager.java:862)
	at
org.openide.explorer.ExplorerManager$1SetRootContext.run(ExplorerManager.java:48
7)
	at org.openide.util.Mutex.readAccess(Mutex.java:362)
	at org.openide.util.Mutex$1R.run(Mutex.java:1301)
	at
org.openide.nodes.Children$ProjectManagerDeadlockDetector.execute(Children.java:
1831)
	at org.openide.util.Mutex.doWrapperAccess(Mutex.java:1320)
	at org.openide.util.Mutex.readAccess(Mutex.java:351)
	at
org.openide.explorer.ExplorerManager.setRootContext(ExplorerManager.java:499)
	- locked <0x1aed5e98> (a java.lang.Object)
	at
org.netbeans.modules.maven.navigator.POMModelPanel$4.run(POMModelPanel.java:328)

	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
	at
org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:133)
	at
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269
)
	at
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174
)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Found 1 deadlock.
Comment 1 Sergey Lunegov 2010-05-12 13:40:12 UTC
Reassigned to maven
Comment 2 David Simonek 2010-05-12 14:41:12 UTC
actually duplicate of 185923, happened to me yesterday.

*** This bug has been marked as a duplicate of bug 185923 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo